loading

Adcom Amp GFA-555 II hissing out of the right side..too old to fix?

My Adcom GFA 555 II amplifier is producing a slight hiss/static sound from the right side. I made sure by switching the cables, and swapping terminal contacts and its always the right side (red and black). the music comes along with it, but its annoying to hear along with the static. You hear it most on quieter passages. It was coming and going, but now its heard all the time. I guess i have to take it in to fix, but its 20 yrs old, and i worry about paying to fix a broken part, only to have another part fail a week later.

appolo8 years ago
I'm not familiar with your amp, so I presume it's a stereo Hi Fi amp? However I do have a lot of experience in servicing stereo HiFi equipment from this period. Is this a tube / valve amp or transistors? If the hiss decreases with the volume setting and can be accentuated with a treble boost control ( if amp has tone controls) then your fault will most likely be in the per amp stage and quite possibly be caused by a noisy pre_amp semiconductor (transistor) or tube / valve. The pre_amp circuits have the most gain or amplification so it's likely this stage will be at fault. Should the hiss remain audible when the volume is turned down to minimum, the problem will be farther back around the output stages of the amp circuits. For stereo amps components, especially tubes / valves can be substituted between left & right hand channels. Without some electronic knowledge however in depth circuit analysis may be required using test equipment. One last tip I can offer... If this is a valve type amp I have known similar problems caused by valve bases and valve pins that need cleaning. Electronic hobby stores usually stock aerosols for cleaning switch contacts etc. Hope this info is useful. Regards.
Sandisk1duo8 years ago
it could be other electronic device plugged into the same outlet/circui