Add simple tone control problem

Hello , i have a problem when im making my portable amp.I use the little MK2 schematic , but i want to add a simple tone control , then i place the tone control between buffer output and power amp.But the problem is noise.When i turn down all knobs (treble,mid,bass) the noise decrease but still noticeable.When i turn up the Treble knoble the noise is very loud .I dont know why and how to fix it.Please help!
Thanks very much !

sorry for my bad English.

Picture of Add simple tone control problem
gmoon5 years ago
That's pretty much a stock Fender style tone stack.

If you're feeding it from a buffer, that probably has a low enough output impedance to drive the stack effectively.

At this point, I'd look for wiring problems (cold solder joints, bad routing), shielding issues or a ground loop.

Are you using quality cables? Is your audio source noisy to begin with? Have you tried other guitars?

And was the circuit quiet before you inserted the tone stack?
login721 (author) 5 years ago
Thanks for helping me !
May be the problem is i not feed the tone stack with a buffer but the guitar .
Since you have the problem when most of the signal comes through the 250 pF capacitor, have you checked it out? Is it good? Have you switched it for a known good one? Also, is the 250K potentiometer (that is the output) good? These are the first things I would check. Then follow gmoon's and steveastrouk's advice.

A couple of search results:
Duncan Amps tonestack
RunoffGroove's Tonemender
Another Instructables question
ClassicTubeAmps article with links

These should help somewhat. Let us know you resolve the problem
.
Qa
Increase the capacitors, decrese the resistors and try again. The problem is probably the impedance of the filter you use.

Look for "Baxendall tone control" as a search term, and see what that gets you ;-)

Steve