Any one here have an idea as to the wiring diagram of a Astec AA20540 computer power supply?

Here's the problem. I took the 20pin header off an old ATX motherboard thinking I could just match the wire colors and presto, a working PSU. Unfortunately the before mentioned unit doesn't seem to have the same color codes for the voltages and/or standby power/wake wires. See I do know a little about them. Normally the green wire, when grounded turns the unit on. Not the case with this one. It's plenty frustrating I can assure you. I don't exactly want to go just randomly shorting out different wires to find the right one either. I want it to work when I'm done. Help, I've looked everywhere else.....

sort by: active | newest | oldest
DamianD13 years ago

I "hacked" this suply. Astec 20540 HP. The main problem here is the 3V "check" loop. You start this suppy when violet wire connected to ground (like in ATX), but the green wire should be connected to orange wire (orange that gives 3V), and red - black should be connected to load that draws around 0,22 A.

so:

6-5 - from 20 in connector

2 - 20 (load 22 ohms) - try to connect a cu cooler - from 12 pin connector

11 - 20 - from 20 in connector

check wiring in jpg file above

beng474 years ago
Hi everyone ,
I have an Astec AA20540 computer power supply (HP Server) and I would like to start it.
I have plugged a load (20W Light bulb) on the +5V, and grounded the green wire, and connected the brown like Wrecd said.

The light bulb blinks and the psu fan turns slowly.
What can I do?

Thanks for your answers!


Astec_AA20540_start.png
Koil_01 (author)  beng474 years ago
I would have to see an actual picture of the wiring pinout as listed by the manufacturer. From what I can see it looks as if this is incorrect for the PSU your using. Normally depending on the specific manufacturer, the brown is connected to either the 3.3 or 5v as a "Power OK, sense" line to let the computer and the supply know that it's OK to start full function. The purple is standby power and shouldn't need to be connected at all. This is the reason I would need to see a full pinout or board schematic for the PSU your using. Otherwise it's really hard to determine exactly what's happening. I'm not very familiar with HP servers... I've always used SUN Microsystems myself. I'm currently using an
X5710C-06 (See image) stand alone unit as an example.
Sun Microsystems X5710C-06.jpg
wrecd8 years ago
the brown remote sensing wire has to be connected to the orange 3.3v line (i think this psu has 3 orage wires, connect to the thinnest orange wire) then take the 2 wires and attach to pin 11.

the green has to be grounded for the psu to power on.
lemonie8 years ago
It's obsolete! (The best I could find was this: http://www.plccenter.com/buy/ASTEC+AMERICA/AA20540). See if you can find out what type of board the PSU was designed for and work off some pinout for the board?

L
Phil B8 years ago
Have you checked Mueller's "Upgrading and Repairing PCs?" He has a chapter on ATX power supply pinouts. That might be of some help.