Ardiuno Ethernet W5100 ic solder bridged?

hi I got a Ethernet shield for my arduino I have ordered, but the problem is that the solder on the IC seems to have run and bridged the connections. I have some pictures taken with a lens I had laying around...

This is what I found.

Please can you help me decide weather I should take it back for a full refund?


Picture of Ardiuno Ethernet W5100 ic solder bridged?
IMG_0666.JPG
IMG_0668.JPG
IMG_0674.JPG
IMG_0675.JPG
IMG_0673.JPG
sort by: active | newest | oldest
frollard5 years ago
Looking at the pcb design, those pads all seem to be connected to ground, so it might even be meant to be like that

does the shield work?

if it's not meant to be that way, poor. Well, I'd ask the seller for a refund...and barring that, get some desoldering braid -- it's cheap online or at an electronics shop (2-10 dollars a roll) and you just lay it over the pins, then heat them to suck up the excess. usually removes most bridges like this.
Daniel Deacon (author)  frollard5 years ago
i havent had a chance to test it yet as my arduino board has not come in the post yet
There are a lot of grounds on that chip, and I ain't going to work 'em all out - check out the datasheet and see what's what
Steve
Daniel Deacon (author)  steveastrouk5 years ago
Do you have any idea where i can find the data sheet just google the part number on the IC?
Yep.
lemonie5 years ago
Does it work? Answer that first.
It's probably deliberate since the pins are connected on the PCB anyway.

L