Arduino Uploading Problem?

Hello,

I have an Arduino Duemilinove with Atmega 328 and Arduino 1.0 programming language. I am using a Mac. Whenever I try to upload a program, It tells me avrdude: stk500_recv(): programmer is not responding. I have downloaded all the drivers and normally the port that the Arduino is on starts with  /dev/tty.usbserial, but that does not show up. I have tried on a PC also and it doesn't upload either.

sort by: active | newest | oldest
Its not impossible the bootloader is corrupted on the Arduino. Are you sure the device is ennumerating in Windows and Linux ?
D5quar3 (author)  steveastrouk5 years ago
How would I tell if it's ennumerating?
In Windows, use Device Manager, in Linux, I think you say cat /dev/usb
D5quar3 (author)  steveastrouk5 years ago
I have checked device manager and it does not show up.
It should show up in Serial ports ?

Last chance: Try a different cable.


D5quar3 (author)  steveastrouk5 years ago
Already did. I have tried with four different cables.
Broken board :-(
D5quar3 (author)  steveastrouk5 years ago
Well, at least it was a good run.
The FTDI chip is the "USB-ness" of the board. Its not that expensive a chip, and it could be replaced.
frollard5 years ago
So, the com port (or dev/tty.usbserial) isn't showing up when the unit is plugged in?

Confirm the arduino environment is looking for a dumil with 328 and the port is actually showing up in the list - reboot/reinstall?

worst case your chip has some fuses set wrong and I have no idea how to fix that.
D5quar3 (author)  frollard5 years ago
Also, when I try to upload, the RX and TX LED's don't light. So that tells me it is not getting anything. And i rebooted the computer and used 1.0 and 0022 vesions of IDE