loading

Arduino and Bluesmirf?

HI,

I have an arduino uno and I am trying to use a BlueSmirf to light up an LED. The problem I am having is that whenever I plug in the Bluesmirf, I cannot update the script on the arduino.  When I do, I recieve this error message :avrdude: stk500_getsync(): not in sync: resp=0x00. I have been able to connect the Bluesmirf to my computer, but I have not been able to get it to reply or to recieve data.

Best Wishes
Amantux

sort by: active | newest | oldest
hanksanders5 years ago
Check out these posts:
http://www.chetanpatil.info/1/post/2011/12/controlling-led-wirelessly.html

http://www.buildcircuit.com/how-to-change-baud-rate-of-bluetooth-modem-bluesmirf-gold-using-arduino-terminal/

They have helped me getting something similar to work.

amantux (author)  hanksanders5 years ago
Thanks those were great!!!!!
The blueSmirf is a rovingnetworks RN41 or 42 module. If I were you, I'd try tying pin 16 (CTS) of the RN41/2 to the 3.3V supply rail WHILE you are trying to download a sketch.
im having similar problem as amantux but im using the blusmirf gold. can you help plz
Jayefuu5 years ago
I used to get that error when the Arduino drivers weren't installed correctly. Can you upload any other sketches?

What OS are you using? If Windows, go to devices and see if your Arduino's listed under USB devices or unknown. If unknown, it's not installed properly.
amantux (author)  Jayefuu5 years ago
I am using the 1.0 release of the arduino devolopment environment with an arduino uno. If I remove the Bluesmirf, I can upload sketches to the board, however, once the bluesmirf is connected I cannot
Hope that helps
Amantux
im having the same exact problem! some one help please
That's probably because the bluesmirf is using some of the same lines that the Arduino bootloader uses.

If you HAVE to have the 'smirf connected, find someway to "tristate" its serial lines when you want to upload a sketch.
amantux (author)  steveastrouk5 years ago
Okay Thanks