Bluetooth speaker not turning on?

Hi, i made a basic DIY Bluetooth speaker with a glass box.
I used one 18650battery from old laptop, a charging module with protection circuit inbuilt,one stepup module to step up 4v to 5v and a 3w amplifier.
It's a basic project, but the thing is WHEN I TURN THE SWITCH ON(AMPLIFIER POTENTIOMETER IS OFF) I SEE LED BLINKING ON BLUETOOTH MODULE, MEANS IT'S WORKING ,THE CIRCUIT IS OK. THE MOMENT WHEN I TURN ON THE POTENTIOMETER ON OF THE AMPLIFIER THE SPEAKER JUST SOUNDS LIKE "TICK" AND BOOM EVERYTHING SHUTS OFF. I TRIED TO MEASURE THE VOLTAGE COMING FROM STEPUP MODULE SAYS "0"V.
SO I PLUGGED A CHARGER ON CHARGING MODULE AND THEN TRIED TO TURN ON AND FIRST 2 SEC SPEAKER MAKES SOME SOUND AND IT TURNS ON AND PLAYED SOME MUSIC, IT WORKED GREAT.
THE THING IS WHENEVER I'M TURNING ON THE AMPLIFIER VIA POTENTIOMETER OR THE POTENTIOMETER IS ON AND I SWITCH ON THE POWER FROM THE FIRST SWITCH THE POWER CUTS. SO WHAT'S WRONG WITH THE SPEAKER. PLEASE TELL ME :(

Picture of Bluetooth speaker not turning on?
sort by: active | newest | oldest
iceng1 month ago

From what you said..

I would simply jumper a wire across the potentiometer switch portion..

iceng iceng1 month ago

Very nice schematic drawing !

Sayan_trex (author)  iceng1 month ago

Sorry I'm not pro at these.

Sayan_trex (author)  iceng1 month ago

Tried, but same it's not turning on, always have to put a external charger for 2-5 sec

leylah43951 month ago

I would maybe put in a different battery..

Sayan_trex (author)  leylah43951 month ago

Tried changing the battery, same result

Draw a DIAGRAM of ALL the interconnections. Let's see what parts you used.

And don't type in all caps. It looks like you're shouting.

Sayan_trex (author)  steveastrouk1 month ago

Here it is, and sorry for all caps, just wanted to highlight problem area. Thanks

IMG_20171111_211118.jpg

Well the PAM8403 is rated for only 2.5 v minimum voltage, so the boost circuit you used is probably not needed. Likewise, a lot of BT modules will run on 3V, so its well worth trying the output of the charging module directly to the rest of your circuit.

Sayan_trex (author)  steveastrouk1 month ago

Not working, still i have to put a charge on charging module to start up the device, tried changing the battery but same thing happening, the speaker isn't turning on , i have to turn it on with a help of charger everytime :(

What voltage do you measure at the output of the battery on the TP4056 ? What do the LEDs show ?

Sayan_trex (author)  steveastrouk1 month ago

Red led- charging, blue led- charging done.

It shows 4.11v