Can anyone help me fix my K'NEX Serpent's Spiral Coaster?

I've built this model a year ago and i just recently built it again and for some reason it gets stuck right after it goes on the first u-turn around the front. When i first built it, it worked fine, now it wont work!! And suggestions? Please help me. Whose ever answer is the best, will recieve a 5* on all of their instructables. So please help me. By the way I'm an experienced builder but I cant come up with any solutions. There is also a video. Click_here_for_video.

sort by: active | newest | oldest
Dr. Pepper6 years ago
Who made it originally? If you did then you need pics that would help us understand more. If someone else made it originally then just ask them to help you.

DP
Nothing2it (author)  Dr. Pepper6 years ago
i made it idk if i can get pics though cuz my webcam sucks and my phone has no service so i cant send pics with it. If you have the instrutions you can look at maybe.
You can put pics on the internet right? I'm not really a K'nexer so I don't really know how to fix it. It would be so much more help if you got pics and then sent it to some other k'nexers and they could help. That's the best I got.
Nothing2it (author)  Dr. Pepper6 years ago
Go on youtube.com, I've posted a video on it. My username is nothing2it23(this is the exact spelling and its all in lower case), so take a look at it on there. If that might help you.
Show it to some other knex people. They can help you more than me. Oh, it would be awesome if I could have the best answer too. I subbed!
Nothing2it (author)  Dr. Pepper6 years ago
thnx btw ill give your ibles 5*'s any ways
Cool! Can I get the best answer too?
Nothing2it (author)  Dr. Pepper6 years ago
Sure, why not!