loading

Can anyone suggest what's wrong with my power supply?

I have a Maplins N93CX Switching Mode Power Supply. It has worked fine for the last 5 months or so, but just under a week ago I shorted the terminals, and normally because of all it's current limiting and stuff is absolutely fine with this but this time it just suddenly shut down, blew the the fuse internally and the one in the plug. GRRR. I seem to have located the fault on the mains side as with a dim bulb tester the bulb will instantly light with it switched on.

Another thing I have noticed which I find very weird is that if I measure the resistance across the live and neutral mains in it will at first measure just under 1 Megaohm, however if I short the terminals then measure the resistance will go down to 500kohms! 

I should be able to post a picture of internals if anyone needs.

sort by: active | newest | oldest
Don't forget how these things work, a high voltage rectifier turns mains into high voltage DC, then a transistor chops that at high frequency into a special transformer, then the output of that is rectified and controlled ( adjusting the chopper transistor BACK across the isolation barrier)

Start looking at the main chopper transistor and be VERY VERY careful - there is top end of 400 V present, and from a capacitor which can KILL.

Steve
framistan6 years ago
Your measurement of 500 k ohms or one megohm is an OPEN. If you test that at the AC input power cord... then you either have an OPEN transformer primary winding... or a fuse in series with transformer primary is open.
lemonie6 years ago
Why did you keep shorting the terminals? They're not designed to take that repeatedly I should think.

L
rickharris6 years ago
At £80 I would look further to repair eve if that means changing the components one by one.

getting a circuit diagram would be a BIG plus.

Possibilities:

1. You have fried a component - in order of likelihood - Output rectifier, the controller, the output transformer

2. You have fried part of the circuit board. Visual check may help here

3. You have fried a resistor of capacitor in the circuit - you may be able to see or small something wrong.

An oscilloscope will be a great help to fault find.

AndyGadget6 years ago
I've always found that when switched mode PSUs go pop, they really go pop! Never have I had one where it's just a case of replacing one component. There's always been few components fried. Don't replace all the faulty components and the thing goes POP again when you turn it on for testing. Troubleshooting will probably be more trouble than it's worth - Get a new supply.