Circuit Problem?

Hey guys i just made this circuit ( pic provided ), The problem is when i  clap the led that indicates the circuit is off turns off (power goes to the relay coil) but  the circuit off indicator led turns back on after a few sec and the relay does turn on at all. (Yes the relay works) And another thing I observed is that when i take the coil wires off and attach them to an led instead of relay it works correctly and the led stays on till i clap again to turn the circuit off.

Picture of Circuit Problem?
sort by: active | newest | oldest
Wired_Mist1 year ago

Looks like "T1" (BC547) is limited to 100ma; This may not turn the relay on.

Do you have a transistor with a slightly higher current rating?

My personal fav in the TIP120/122 but a different transistor may help you out !

shahryar.adil.3 (author)  Wired_Mist1 year ago

i think thats the problem myself, i have a mje13003b and a 13005s

You could try to measure the current that the relay uses to turn on. just hook the coil directly up to your 5v source and measure the current the coil is using. Then take the same measurement on your circuit.

If there is less current across the relay then what it used to turn on by it's self then that would be your problem.

shahryar.adil.3 (author)  Wired_Mist1 year ago

I dont have an ammometre (< whatever you call it) or a multimeter. :(

If you are going to continue to have some fun with electronics, it's a must have ! it's almost as critical a tool as a soldering Iron. they're not too expensive. cheapest are like $10 but if you can get one for $40-ish it might suit you better :) should be able to find one in a auto parts store if your local electronics shop doesn't have one.

And thanks for the Best Answer :D

Good luck; Let me know how it turns out !

iceng1 year ago

Pin 12 the carry out should be left unconnected.

Otherwise this is wired like a sound flip-flop and the op-amp needs a hysteresis with a small cap feedback to avoid random stop not clap on clap off.

4017.GIF
shahryar.adil.3 (author)  iceng1 year ago

Thanks, that worked :). Now the only problem is that the relay wont turn on even when directly connected to the battery :(.

Sounds like your battery is low or the relay is damaged.

shahryar.adil.3 (author)  iceng1 year ago

Relay is working. Turns out it was the battery. Currently experimenting with Phone Charger;

If you use a battery make sure to use a very low power relay, standard relays will need more juice than what the battery can supply.
Depending on what you want to switch a triac, mosfet or power darlington transistor would be a better choice.
Maybe even a SSD if you need to switch a lot of power or AC mains.

shahryar.adil.3 (author)  Downunder35m1 year ago

Yeah, I figured that out. The relay wont even turn on when directly connected to battery :(.

+1

Switching to a mosfet (triac for AC) will bring the current you require down quite a bit.

The relay is too low resistance on the coil side for your 9V battery.

shahryar.adil.3 (author)  steveastrouk1 year ago

Will a 9v wall mart work?

Yes, probably. Try it.

What voltage is the relay COIL rated at ?

shahryar.adil.3 (author)  steveastrouk1 year ago

Sigh, not working with a 5v phone charger.

shahryar.adil.3 (author)  steveastrouk1 year ago

Thats the only relay my electronic shop carries :/

The coil is rated at 6v but it seems to work at 5v. At the moment i do not have a 9v power supply or 12 qwallmart with 9v regulator ill try it with a usb phone charger.

Phone charger should be ideal. Let hope there is enough voltage.