HP Laser jet 4 installation?

Dear All
I have an old printer HP Laserjet 4 model C2001A (please see photo) and have a problem when installation it to my computer windows 7 ultimate .Because I cannot found my model C2001A on list of (INSTALL THE PRINTER DRIVER) before and after UPDATE.
So please help me to know what I can do for get rid of this problem, I hope you understand my question and help me Thank you very much
                                       Best regards
                                         lam

Picture of HP Laser jet 4 installation?
sort by: active | newest | oldest

Just use the HP laserjet 5, same drivers anyway, just slightly different features.
But makes no difference for the print.

lam (author) 1 month ago

Dear Downunder35m

First thank you so much for your help.
Unfortunately I am an old man and is bad in programme computer . So please help me again by show me what model of HP in list you used (ADD PRINTER) please see photo .Thank you

ins 1.jpg

Can't really say what models are in your list but anyhing supporting PCL4 or PCL5 from HP should if the format (e.g. A4) is the same.
I have several HP Laserjet 4 models in my printer list from Win7, same for Laserjet 5 and 6.
You should have the same as it is a Windows default driver.
Just scroll down your printer list and select one of the corresponding Laserjet 4 models with support for PCL.

lam (author)  Downunder35m1 month ago

Dear Downunder35m

Thank you very much for your time concern and advise me and now it well working.
Best regards
lam

You're most welcome!
I still use some old HP lasers myself, so I know your pain with the drivers.
Thankfully these old HP's from the 4,5 and 6 series are working with the same basic driver.
Only the paper handling and other stuff you can adjust is different but the normal printing even works with the "wrong driver".

Vyger1 month ago

Go to HP web site, look up the printer under support and download the latest drivers and install it using the files they give you.

Many older printers are no longer supported by all operating systems so it may not work, you need to check the web site.

lam (author)  Vyger1 month ago

Dear Vyger

(Many older printers are no longer supported by all operating systems so it may not work, you need to check the web site.)

Yes ! You're right Many thank you.