Instructables

Has anyone built an NAS before?

I'm trying to build an NAS with a spare computer I have. I'm trying to run Freenas, but every time I try to install the OS, I get a read error: 0x20
The computer in question is an old alienware M9700 my cousin gave me. For some reason, the computer doesn't give me the option to boot from a flash drive, so I assume it can't. So here are my questions:

1. What is this read error I'm getting? I've tried googling it, but I've only gotten very mixed results on it.
2. Is it possible to run Freenas this way? (without a flash drive, via disk)
3. Since the laptop has two SATA ports, could I install the OS to a smaller HDD, and then use the remaining as the storage space? I've been told that you can't install the OS onto the same drive intended for storage.

tylervitale (author) 1 year ago
Nevermind, I sorta figured it out:
I was trying to install the x86 version on my computer. Even though my computer is 32-bit, I said "what the heck" and tried installing x64. To my surprise, it worked. (screw logic)
Maybe the 32-bit version doesn't work for some reason?
Anywho, it works now. Thanks for your suggestions!
Perhaps you are trying to read a DVD with a CD drive?
tylervitale (author)  Awesome-aniac1 year ago
Is this just speculation, or is there logic behind it?
That probably sounds really arrogant, but I just want to know if you know exactly what this read error: 0x20 means.
I was just throwing it out there as a possibility. I wouldn't get to hung up on the error code, it could mean just about anything. Point being, there is an error and that's all we know to start.

What part of the install process triggers the error?
tylervitale (author)  Awesome-aniac1 year ago
It isn't the install process, it's before that. When the computer attempts to boot from disk.
It could even be a BIOS specific error message.
Pro

Get More Out of Instructables

Already have an Account?

close

PDF Downloads
As a Pro member, you will gain access to download any Instructable in the PDF format. You also have the ability to customize your PDF download.

Upgrade to Pro today!