loading

Hello, I have a TLC5940 connected to an Arduino runing off 9v mains power and 14 LEDS.


My problem is that the leds will only illuminate when my finger is held near the legs of the LEDs. Pushing down on the TLC5940 also lights them, I suspectded a short circuit on my breadboard, but if they're lighting up with my finger near them, surely not a short? I have built this on three different breadboards, same result every time, also tried swapping chips!
Attached pic shows the circuit.
Any ideas greatly appreciated as this has me tearing my hair out!

Picture of Hello, I have a TLC5940 connected to an Arduino runing off 9v mains power and 14 LEDS.
sort by: active | newest | oldest
Odds-on you've got an open circuit on the "blank" pin, or you have it tied low and nothing on the greyscale clock line.
inbox.jason (author) 6 years ago
Blank connects to pin 10 then 2.7k resistor then +ve. I've had this working in it's entirety, so this is highly frustating.
This is why I hate breadboard, and always solder circuits together.

Steve
inbox.jason (author)  steveastrouk6 years ago
It was indeed the breadboard causing my woe! Many thanks for all your input!
Guess I'll need to learn to solder!
Well done on isolating the fault. Some day soon, I'll write up some notes on prototyping without breadboard.

Steve
Why the 2.7K resistor ?
inbox.jason (author) 6 years ago
2.7k resistor is a pullup resistor on blank, turning all outputs off when arduino resets. I've remeoved it to no avail! Would a chip holder make any sort of difference? Still guessing a short circuit, as my hand nearby illuminates all leds...
Or could I be developing super powers??
Its this "nearby" business makes me sure you have an open circuit, rather than a short. It is ENTIRELY likely your breadboard is broken, and you can't tell ! I HATE BREADBOARDS. THEY LEAD TO MADNESS ! MADNESS !

If you haven't an oscilloscope, A trick I use is to deliberately ground myself to the PSU, and touch the pins with a metal probe. An open circuit pin will make SOMETHING happen, often. Failing that, tying myself to +5 can work too.

If you have a scope, its easier. Touch the pins with the probe, AND touch the probe. Bad pin - noisy trace on scope.
inbox.jason (author)  steveastrouk6 years ago
I'm thinking it's my breadboard as well! I'll build the same circuit onto a breadboard I know it has worked on before. A pain becuase that board is in use but I need to get to the bottom of this!
I'll let you know how I get on tomorrow.

Thanks a million for your prompt replies Stevestrouk, you truly are a lifesaver!