Help, my pc has NO audio!

My pc has no audio and i'm getting PlSSED! Every time it says "No audio device detected!". Yes, yes I have my speakers plugged in and volume up no mute, EVERY VOLUME FULL, play youtube with no mute AND...no sound!

sort by: active | newest | oldest
omonoia6 years ago
Do you remember what audio device it was?you can download it again.
lemonie6 years ago

I'm getting pissed too, but that has a different meaning for me....
Listen man, "No audio device detected!" means that Win' can't find an audio device which it can use.
Have you checked the Device Manager for little !warnings?

L
Tom1795xx (author)  lemonie6 years ago
I have checked EVERYTHING but then i find the options for sound devices is gone!

Device Manager?

L

Tom1795xx (author)  lemonie6 years ago
Device Manager>Sound, video and game controllers>Legacy Audio Drivers Then I see a message. "Realtek AC'97 not found!" Please tell me where to get an audio driver.

OK, now we can see where a problem is?
Try this, it would seem to be a popular search:
realtek ac'97 audio driver download free (Google)

L
Tom1795xx (author)  lemonie6 years ago
I have got my grandfather to fix it but thanks anyway. YES I HAVE SOUND!!!! :D
Good, what was the fix?

L
Tom1795xx (author)  lemonie6 years ago
I downloaded the realtek audio player which came with my computers default drivers.

OK, there we go. It's nice to have these things answered.

L
Tom1795xx (author)  lemonie6 years ago
Yah I really agree.
Tom1795xx (author)  lemonie6 years ago
I downloaded a Realtek AC'97 Audio Driver but it said it was an invalid application. I followed the instructions. I should just buy a sound card.
orksecurity6 years ago
For what it's worth: This would be a heck of a lot easier to diagnose and solve if we actually had our hands on the system. I strongly recommend finding someone local to you who can work through the problem with you, showing you how they're doing it as they go.

Personal reaction: The error message you cite sounds as if you have installed audio drivers for a device which is either missing or malfunctioning. I'd want to play with it a bit more to be sure, but I repeat my suggestion that you try dodging the whole bullet by plugging in, and installing drivers for, a new set of sound hardware.
Tom1795xx (author)  orksecurity6 years ago
I downloaded my system's original drivers but it was an "invalid application" :P I'm just gonna get a new sound card.
NachoMahma6 years ago
. First thing I would try is re-installing the driver(s) for the sound card. You should be able to download the latest version from the manufacturer's web site.
.  If that doesn't work, try unplugging the sound card from the mobo and then plugging it back in. This will often clean any dirt or corrosion that may be causing a problem.
.  Check the headphone jack. Most have a built-in switch that turns off the speakers when headphones are plugged in.
Tom1795xx (author)  NachoMahma6 years ago
It is not the sound card it is in and clean, I have drivers installed, but no sound still! :(
try looking for an update to the driver or uninstalling/reinstalling it. Might work....
Tom1795xx (author)  astroboy9076 years ago
I get a message "Windows update can not update your computer."
orksecurity6 years ago
1) Are you sure the sound hardware is good? It may be defunct.

2) Is the sound card configured to output to the internal speakers or external? If external, are you sure THEY are good and wired/plugged in properly?

"No audio device detected" means the drivers can't find working sound hardware which matches them. If you're still getting that message, I'd try finding another sound device. There are some high-quality USB sound interfaces available at fairly low prices; I use one to interface to my stereo system and another one (on another machine) for dubbing/editing old tapes and recent field-recordings. (Haven't switched to all-digital for the latter yet.)
Tom1795xx (author)  orksecurity6 years ago
But there is no options about any of that in sound devices. :(
rickharris6 years ago
It may well be that you have selected the wrong output device for your system - Do you have an internal sound card AND an separate sound card?? Go into the control Pnl and make sure you select the appropriate output.

i can use my sound blaster card OR the internal output.
Tom1795xx (author)  rickharris6 years ago
I am using the internal output with legacy audio drivers, sound card is clean and installed, but STILL no sound!
Like Nacho says, its lost the drivers for the internal sound card.