Help using a Neptune FS-100 flow sensor with an Arduino/pi?

Hey folks,

I'm trying to detect a flow in a 1" pipe with a flow sensor. The best one i could find was made by this company called Neptune (FS-100)

It looks like a basic hall effects flow meter but i am trying to get it to talk to an arduino and I seem to be failing.

It has a TRRS 3.5mm plug on it. I used a volt meter to determine which color wires inside correspond to the TRRS:

Tip: RED
Ring: ?? White ??
Ring: GREEN
Sleeve: Black

can someone help me figure out how to get this thing to talk to my arduino?

thanks so much

sort by: active | newest | oldest
saltyrover (author) 2 months ago

what exactly does this resister do in the circuit?

The product says it is limited to 1500 gal per hour

What exactly is causing that limit? Is it just the resolution of the blips as the wheel turns around, turning so fast (at greater than 1500gph) that you can resolve the blips?

steveastrouk2 months ago

You've got it.

Black = 0V

Red = 5V

Green = signal out

There are rebranded Allegro Semi chips I think.

saltyrover (author) 2 months ago

The markings on the hall effect sensor look like 460S which google tells me is a honeywell hall sensor: http://www.mouser.com/ds/2/187/honeywell-sensing-s...

3-24Vdc which is sorta in line with what the neptune flow sensor modules say "24V accessories".

I went to a friends house who has one of the Neptune modules for reading these sensors and stuck volt meter probes into the socket and could only find, a max, of like 4.8Vdc so i'm assuming the thing takes 5V input.

Wiring diagram is attached.

The resistor color code makes no sense to me. I measured it using a multimeter and it measures about 10kOhm. Can anyone explain this color coding to me?

thanks folks

IMG_3351.JPGIMG_3352.JPGIMG_3354.PNGIMG_3356.PNGIMG_3357.JPG

Brown-Black-Black-Red ?

1-0-0 and two more 0 0 1000 10K

steveastrouk2 months ago

Join the Neptune Systems user group and ask there. This might be optical, not hall, which would mean it needs 4 wires potentially.

saltyrover (author)  steveastrouk2 months ago

I've opened it up and there is definitely a battery. The PCB has 4 wires coming out of it: one of the four wires goes under the board and out of sight and the rest surface mount with traces going to different locations. I think all the circuitry is hidden under the board and I'm afraid if it take it out of its location, pretty well stuck where it is, I will not be able to get it EXACTLY back to where it is and it will be wonky calibrating it. I can post pics later.

There is a Neptune section on here?

saltyrover (author)  saltyrover2 months ago

MAGNET not battery..... fail at typing early in the AM

steveastrouk2 months ago

Take the cover off and post pictures of the circuit board inside ?

saltyrover (author)  steveastrouk2 months ago

It looks like the white wire goes to the plastic peg that is securing the circuit board...

IMG_3342.JPGIMG_3343.JPGIMG_3344.JPGIMG_3345.JPGIMG_3346.JPGIMG_3347.JPGIMG_3348.JPG
saltyrover (author)  saltyrover2 months ago

detail of white wire

IMG_3350.PNG
Downunder35m2 months ago

You could always use an impeller and a motor to get a proportional DC voltage...
Depends on the required accuracy at low flow speeds though...