Instructables

How can I fix a Band Hero (YES, BAND HERO, NOT GUITAR HERO) Drum kit?

Well, I own a Band Hero Drum Kit, and the Red Drum stopped working, it doesn't respond now. I'd like to know how can I fix this? Oh, and by the way, let me recall that it's a BAND HERO DRUM KIT and it is NOT A GUITAR HERO:WT DRUM KIT! They ARE DIFFERENT!!! Because I checked the instructables manual concerning the WT Drum Kit and the images of the GH:WT drums and BH Drums ARE NOT THE SAME! I hope you can help me out :]. Thanks in advance. PS: Recalling again that is A BAND HERO DRUM KIT, NOT GH:WT.

What you actually mean is: The Band Hero drums released for the Wii in the US, and for all platforms outside the US, are different from the Guitar Hero : World Tour drumset. Since your screen name is WiiLegend, I will assume you are using the Wii version of the drumset, and not a European Xbox or PS3 kit. WFIW, including this kind of information would have been more helpful than the repeated vague statements, random text formatting and exclamation points.
So when we remove all the redundancy, what we're left with is "The red pad doesn't work". This copuld be caused by any number of things, i.e. a bad sensor in the red pad, a loose wire, software problems, the Wiimote not being properly seated, or just Activision/Red Octane's legendary tendency to release shoddy peripherals.
In order to troubleshoot, start with the easy stuff: Swap out the Wiimote with a different one, making sure that it's installed and seated correctly. Or if you only have one Wiimote, take it out and reinstall it. Check to see if there are any software patches available for Band Hero, and get them installed. If you know anyone who has another drum kit, borrow it and see if that works on your machine. If the borrowed kits works and the other fixes don't help, it's probably the hardware. If your drum kit is under warranty, send it back to be fixed. If not, crack it open and check for loose wires. Tap the sensor directly with the drumhead removed and see if it works. Maybe install a different sensor entirely, if you can get one. Try following the instructables for fixing the GH:WT kits. It's really only the externals that are that much different.  Failing that, you'll need to get a new or refurbished kit.