Instructables

How can I open .mod files in linux (ubuntu)?


I am trying to open a .mod file in ubuntu. Every program that I have tried has failed right away. I have tried, vlc, real player 11, and everything that comes installed in ubuntu. Please help me get this file open. Thanks

TOCO if you haven't already... you could try converting the file using mod2avi (which uses ffmeg)... I think vlc should actually play them, I wonder why the grief... perhaps it parses it as a synthesized mod audio file... this is the problem of parsing with respect to file extension instead of data it contains...
TOCO (author)  rocketsurgery3 years ago
I tried all of the same stuff that is posted already in windows and ubuntu but still nothing.
You're sure the file didn't get garbled when you downloaded it, right?
TOCO (author)  orksecurity3 years ago
it is a file that came in ubuntu. I dont know if it is from 9. whatever or 10.04. I had 9 but then upgraded via update manager to 10.04. It was the highest that I could go because it says that 10.10 wont run because I have 2mb less ram than is recommended.
Burf3 years ago
Well, I'm not sure what your problem is, but I downloaded a .mod sample file from the net.
Using Ubuntu 10.10. I was able to play it without any changes or problems whatsoever in both VLC and Movie Player.
I then changed the file extension to .mpg and again it played perfectly on both players. I know for certain that a .mod file is an mpeg with the file extension renamed.
All I can figure is that either the files you have are corrupted, you don't have the right codecs or you didn't properly rename the files.
Try this: Right click on the file and then click Properties.
In the Properties window in the name box, highlight the letters MOD after the period, and type in mpg
It should look like this... Movie Name.mpg and then close the window. Then try to open it with Movie Player or VLC. If that doesn't work, then the files are corrupt or you need to download the codecs.
TOCO (author)  Burf3 years ago
I am trying to open places>computer>filesystem
Burf TOCO3 years ago
Change the file extension the way I posted above.
TOCO (author)  Burf3 years ago
i tried to and it said that the proper plugins werent there and it couldnt find them online.
Burf TOCO3 years ago
Which release of Ubuntu are you using?
TOCO (author)  Burf3 years ago
I had 9. something but I upgraded to 10.04. I thought that it was 10.10 but I guess not.
TOCO (author)  Burf3 years ago
I have already tried that. I can try a different file.
seandogue3 years ago
TOCO,

Have you checked here for a Linux suitable modplayer?
btw, what is the name of the modfile? Are you sure it's actually a mod music file? there are other files that use the .mod extension that have nothing to do with music... It is also possible that the file has been corrupted. You could always redownload from a trusted source like ModArchive to make sure.
Burf3 years ago
Try an easy one first by changing the file extension name to .mpg instead of .mod and open it with Media Player.
TOCO (author)  Burf3 years ago
I tried all of the same stuff that is posted already in windows and ubuntu but still nothing.
TOCO (author)  Burf3 years ago
I tried doing what you said and I got the same result as I did when it was .mod. If you have any other suggestions I am open to them. Thanks for the help so far.
Pro

Get More Out of Instructables

Already have an Account?

close

PDF Downloads
As a Pro member, you will gain access to download any Instructable in the PDF format. You also have the ability to customize your PDF download.

Upgrade to Pro today!