loading

How do I burn a bootloader onto an Atmega1284P?

I am trying to burn a bootloader onto an Atmega1284P chip.
The chip is marked Atmega1284PU.
I am trying to follow this instructable: https://www.instructables.com/id/Arduino-atmega6441284-clone/
I have tried it on different computers and different installations of the Arduino IDE, Including a computer with a fresh install of both.
What ever I do I get this error message:

avrdude: Yikes! Invalid device signature
         Double check your connections and try again, or use -F to override
         this check.

Please help Thank you
JRV31

sergiotux1 year ago

may help you

https://maniacbug.wordpress.com/2011/11/27/arduino-on-atmega1284p-4/

Have you tried the over-ride code ?

Alternatively, spend a few bucks on a real ISP programmer for the Atmega chips - I think they are only about $30.

JRV31 (author)  steveastrouk1 year ago

How do I enter the override code from within the Arduino IDE?

You don't I think, you have to hack the file avrdude.conf, which is in the directory ArduinoXXX\hardware\tools\avr\etc

Check of course what signature bytes you ARE reading from the device - it might be as simple as looking in the conf file and checking what its looking for