How do I wire up a TCS-4010 "Love Control" temperature controller?

I wired it up the way the instructions seemed to say and it just popped and sparked.  I am trying to use this temperature controller to control a band heater.  There is a pic of it.  I uploaded a pic of the schematic too.  I guess what I am asking is if someone could explain in a few paragraphs how I wire this thing up.  Maybe you could make a video explaining it and post it in here.  

My band heater doesn't have a ground but my plug does.  Do I connect the ground to anything?

Is the "load" and "common" the same.  It is "load" in the diagram and "com" on the controller

Thank you

-Jacob


Picture of How do I wire up a TCS-4010
IMG_1643.JPG
IMG_1644.JPG
LoveWiring2.jpg
sort by: active | newest | oldest
iceng2 years ago

You wired it correctly but I read on the heater imprint (Super clear pictures)

[OEM HEATER

[5V 50W

This will explode every time you put 120V to it !!

What is the heater for ?

the heater needs a 5v 10amp supply ...

Wow. Good catch. I rarely drill down through the photos like that. I hope he hasn't damaged the internal relay with that 220Amp load.....

It was your comment that triggered my deep search.

We make a natural team :-)

Noblenutria (author) 2 years ago

That is the problem. I tried to connect a 5 volt heater to a 120 volt source. I could not believe that a heater could run on 5 volts. So Thanks for all of the help guys

The Band heater was paired by the engineers, it is a 16A control switch. Here are the heater specs

50W 5V 1 phase, 300F Operating temp.

WHAT "popped and sparked" ? How many watts is the heater ? The diagram is very clear. What did you wire ?

Noblenutria (author)  steveastrouk2 years ago
The heater is 50 watts and it was the heater that sparked. I have a few more controllers and heaters in case I broke the one I tested. I connected hot to 8 and 10 on the diagram and neutral to 7 and the other side of the heater. I connected hot from the heater to 11. I assume it does not matter how I wire up the heater. There were no negative or positive markings.

Is the heater definitely 50W@110V ?