Instructables

How do you trace a drain on the battery of your car with an alarm installed?


My Stratus has enough of a drain to need jumped daily even with long driving. The alternator and battery seem to be fine. I have an alarm that can be turned off but I know it still causes some drain since the LED indicator for it blinks when it is turned off.
How can I trace the drain with the alarm still attached? I don't know where it is wired into the car because it cam with the car, apparently as an available option.

PitStoP1 year ago
I know this is an old question, but I that if the battery cable is not clean or connected tight on both ends(including the ends not connected to the battery terminals) like the positive wire to the starter relay/starter and the negative wire to the ground (on the engine block) it will not let the battery get a full charge when the car is running. Also a bad battery cable can cause this also. Now the other guys that mention the fuse test are right but to add to that just incase you didn't know, some cars have more than one fuse box. Like my car it has a fuse box on the side of the dash and another under the hood! a few more things that can cause a battery to drain is a bad door,trunk or hood switch... If there's a light connected to this switch (like the hood and trunk light you don't see on when it's closed) then your battery will drain. The door can cause the lights inside to turn on (like mine was doing at one time) and drain the batt even when you don't know it! (my car did this but the alarm kept turning on so I knew it was the switch when I observed it for a while and saw he lights insideturn on and set the alarm off) Also a bad radio(that has a faulty power switch) can drain it too.. Now this one also happend to me in the past. A audio capacitor! Yeah I had a Capacitor connected to my amp to keep the lights from dimming when playing loud music with my speaker box/amp set up and this Cap had neon lights built in it so when the remote switch that was suppose to turn the Capacitor on when the radio was powered on went bad then it would turn the Capacitor on and drain my battery. Well thats all I can think of for now. I hope this helps someone else who has the problems! Also if you got this problem fix or found the solution then post it here so we all know what it was that was causing the battery to drain.. Have a great search! =)
Andale_The_Great (author) 3 years ago
sigh....turns out that my particular style of tester cannot detect the 'ripple' effect of a single bad diode. So in the end it turns out to be the alternator even when it came up positive on some types of testers.
One thing you might look at also is your drive belt. It may be loose or old and stretched and is not "charging" enough to last (I call it skip charging). I had a problem very simular and once I put on a new belt it fixed it. Also you may need to make sure the belt tension pully is working as it should, these can go bad and lose tension also.
I just replaced the tensioner when i had the timing belt and all other belts changed about 6 months ago. Not likely candidates. Plus I know from experience that if your belt is skipping you can USUALLY see jumps in the charging system's output. I say usually because sometimes it only slips under power.
framistan3 years ago
This type of problem is difficult to track down the culprit because of several things that can cause the problem. If the battery is getting to be about 4 years old or more... its probably the battery. However it could be any of the following systems: The charging system (alternator, belt, regulator). The STORAGE system (the battery), or the other systems in the car that might be draining it at night. You can buy a digital multimeter at harbor freight tools for $4. or at radioshack for less than 20 bucks. Connect the probes to the AMPS jacks and set the dial to measure 10 or 20 amps DC. Disconnect either battery post (not both of them. Then connect the meter probes -- one probe to the disconnected terminal and the other probe to the battery terminal. Do all this WITH YOUR CAR OFF and the key removed. don't try to start the car during this test or you will damage your multimeter. Your meter should now be measuring how many amps your car uses when the car is just sitting. The reading should be very low. only low MILLI-amps. If it is measuring any AMPERES then it is excessive load and your battery will be dead overnight. To discover what item is drawing too much... jus remove ONE FUSE at a time and note when the amps disappear. Be sure to place all fuses back in the proper spots. Another alternative test you can do is to just use a tail-light bulb connected instead of the multimeter. If the tail light bulb glows brightly... you have a problem... if it barely lights up... then no excessive load is present.

Another thing that can cause your problem is a corroded terminal on the battery. Just clean the battery posts. or a corroded GROUND wire attached to the cars body usually near the battery or the alternator. Or a LOOSE alternator belt.... just check it for proper tension. or an alternator/regulator going marginally bad. LOTS of things can cause your problem and the only thing to do is check for easy things first and just keep looking and eliminate one thing after another and you will eventually repair it.
lemonie3 years ago

The alternator and battery seem to be fine?
Does that mean that there doesn't seem to be anything wrong, or have they been tested?
When was the battery last fully charged (with a battery-charger overnight)?

L
Andale_The_Great (author)  lemonie3 years ago
I used to work as a battery and oil tech at a blue store (*ahem*) and I have a pretty decent knowledge (and the tools) for checking batteries and alternators. The battery was brought in about a month ago for a low-n-slow overnight which I only did because I'd left it sit for about 6 weeks through the cold.

No. They didn't teach us drain tracing, but that's cuz we didn't do electrical work, if we found it to be a key-off drain then we'd just tell them to bugger off.
You said the battery was brought in about a month ago, but is it old, could it have been frost-damaged, has it been fully pumped-up?

L
Andale_The_Great (author)  lemonie3 years ago
it's not cold damage. I know better than to charge a cold battery.
I know enough to know it's not my battery, I'm gonna just have to start doing the fuses trick.
verence3 years ago
The blinking LED of the immobilizer will not drain the battery for weeks if not even for months.

That is is, IF the battery is good and fully loaded. Get your battery (older/broken ones might lose their charge by themselves), the alternator and the charge controller checked. If you are in some automobile club (AA, AAA, RAC, ADAC ...) they might do the check for free.

Do you have to be jump started for every ride or only in the morning (i.e. after a longer pause)? If it doesn't start by itself after a shorter stop, it definitely is battery, alternator and/or regulator.

If that is fixed (or you want to save the money and spent some time searching), try orksecurity's fuse tip. If you want to speed it up, try a binary search approach: Pull out half of the fuses, if the battery is still flat in the morning , the culprit (or at least one in case of multiple failures) is in the other half. But well, that will only work if the battery is good.

Given you can start in the evening (e.g. after a long drive home), you might also try to disconnect the battery in the evening and reconnect it in the morning. No start: bad battery. Start: something drains the battery, try the fuses.

With a new car, wait for about a minute after stopping the car, before you disconnect the battery, some ECUs (electronic control units) might take a while to finish their internal processing and to go to sleep mode.

BTW: If you disconnect the radio from power (either by fuse or by no battery), you might have to enter some security (anti-theft) code to make it work again.
Andale_The_Great (author)  verence3 years ago
I never thought the LED was draining it, but I wondered if it would affect the ammeter reading since it blinked (which would be done by a circuit). I think the radio is okay since I take my batts out every few months for the odd 2 amp overnight (cuz it makes them last longer, you may argue but i've proven it).

It seems an innocuous amount of time. It sat for a week with no problem but had needed jumped the day before. I had to jump it twice this week alone tho.

I wish I could find one of those 14.4 Vdc 2 Amp solar chargers.
orksecurity3 years ago
An LED demands almost no power, by car standards. Ignore it for now and look for other things. One easy way to isolate it would be to pull a different fuse every night (not the ones which would require factory help to reset, of course) and see which one leaves the battery in decent condition in the morning. Then find out what's powered through that fuse and figure out why it's wasting juice.

One classic problem: Do you have a trunk light, and if so are you sure it's going out when you close the trunk?

Andale_The_Great (author)  orksecurity3 years ago
locked a friend in it to find out, i let him out a few days later to make sure he wasn't lying.
:)
NachoMahma3 years ago
.  Disconnect the battery (only need to remove one cable) and see if it discharges overnight. If it discharges, then the battery is probably going bad.

.  If the battery stays charged, then start removing fuses, one at a time, and letting the car sit overnight. When the battery stays charged, you've found the leaky circuit.
.  If you have a decent ammeter, you should be able to watch the current while you pull fuses. When the current drops to (close to) zero, you've got the culprit.

.  As others have pointed out, the LED will not drain a good car battery overnight.
Pro

Get More Out of Instructables

Already have an Account?

close

PDF Downloads
As a Pro member, you will gain access to download any Instructable in the PDF format. You also have the ability to customize your PDF download.

Upgrade to Pro today!