loading

How to fix Food Saver - Vacuum Sealer?

I have a Food Saver brand Vacuum Sealer, that all of a sudden stopped working properly. It has no On-Off switch. You simply plug it in, and then put the bag up to the vacuum area and then press down and hold the lid when its vacuuming the air out and then seals the bag closed.

When it stopped working, a vacuum bag was placed (as we normally would) and then the lid was put down and pressed. The motor is still running, but normally it makes a louder noise as its vacuuming the air out, and this time it didn't work. (No vacuum). Since it wouldn't vacuum the air, it then wouldn't also seal the bag. 

I checked the single air hole on the unit, and there isn't anything obstructing the flow of air, and the bag was put properly in the machine. I also tried using a new bag (just in case the other one was defective) but it made no difference. All the bags come off a large roll. You seal one end, fill it, and then vacuum the air and finally it seals. I've been using this machine for several years with no issues, and this isn't a new roll of bags.

Any ideas on what to do to service it and hopefully get it working again?

sort by: active | newest | oldest
Sounds like a valve in the pumps gone bad - blocked, by the sounds of it. I don't know what pump tech they used inside to advise you further. I'd guess at a diaphragm pump, but open it up and take a look is probably quickest.

Steve
canucksgirl (author)  steveastrouk4 years ago
Thanks for the reply. New photos of the inside have been added.
Yep. Diaphragm pump.

Watch it in action. See that the little crank's turning like fury.

Any cracks in the pipework ?

Otherwise, its open the top of the pump time. There are probably some popper valves in there, or the diaphragm's ripped.

Steve
canucksgirl (author)  steveastrouk4 years ago
I didn't try and run it while the machine is apart. I did take apart the pump unit as far as I could (which wasn't very much). I uploaded 3 new photos. There was a rubber gasket over the holes in the pump unit. There doesn't seem to be anything wrong with the gasket, and there isn't anything obviously wrong with the parts I can see, including the tubes which don't appear to have any cracks or holes.

Any suggestions? (I can't get into the pump area any further. Seems to be a sealed unit.
Does the crank turn freely ?

You're going to have to see what it does with the lid off the machine.

Steve
canucksgirl (author)  steveastrouk4 years ago
I haven't tried that yet, but I will. I was trying to do some online research as well, and someone suggested lubricating the rubber gasket, but didn't say with what. Any suggestions on what I can use on it, and if you think it'll make a difference?
I wouldn't. These things are designed to be run dry.

Can you see the diaphragm moving when you turn the crank ?

Isn't the "top bit" screwed on from underneath, near the crank ?

Steve
canucksgirl (author)  steveastrouk4 years ago
Ok... I put the lid part back, and then the gasket and the top for the pump area, and then started it up. Yes the motor was moving furiously.

So then I decided to give it another try, and successfully heat sealed one end of a bag, and then stuffed something in the bag and tried it out...

And you won't believe it, but the darn thing now works, and successfully vacuumed and heat sealed the bag!

So IT WORKS! ;)

Hey instead of going through that whole process next time use compressed air and spray into the tubes.

JohnW6161 month ago

Having a similar issue with my FoodSaver Mini Plus... it vacuums fine, it just never attempts to seal. I've taken it apart and cleaned everything, but what ever tells it it is time to seal just never activates. I've tried multiple types of bags and rolls. I thought the Mini Plus actually was just based on a timer since it doesn't have a manual seal button either. I know it had worked before on just the beginning of the roll to create an initial seal. Any ideas?

canucksgirl (author)  JohnW6161 month ago

Hi JohnW616. If you haven't already done so, I would suggest doing a thorough inspection of the sealing system. Using a good magnifying glass, check the wire under the Teflon sealing strip for any obvious breaks or discoloration (such as a burn mark). If that appears fine, open up the unit. You should see that the sealing strip wire is held under tension with small coil springs on either end. Check that there is still tension on both ends. If not, it would indicate that there is a break along the wire and it would need to be replaced. If you have access to a multimeter, you could also use that to check for any breaks in the sealing strip. If the sealing strip is okay, I would check the wiring from the sealing strip to the switch (that controls the vacuum and sealing operations). My unit makes a pretty obvious "click" noise when the bag is vacuumed and it begins the sealing; but if you're not hearing that, it could mean a problem at the switch. Beyond that, check all the connectors to the motor and the circuit board for any obvious problems. Let me know how it works out...

Thanks for the suggestions. I tried a few more things with no luck and when I put it together last it now stops vacuuming too (although the pump runs). Could just be a loose tube. Maybe I'll play with it again when I get time. Either way got a killer deal on a replacement - a new damaged box Rival FSFGSL0150-015 at Amazon.
mcgary9111 month ago

I just broke mine out after about 2 years, and it seemed to evacuate the bag ok, but not quite enough to have it seal the bag. I had stored it for so long, the foam rubber gasket was a little compressed so wasn't working as well as it should. I left it out (open) all night and it works fine again this morning. I think when I store it from now on, I'll put something in there so it won't close all the way and compress the gaskets. Nice that I didn't have to crack it open. Since I was on this page, I was obviously ready.

LauraH1632 months ago

I also want to thank the folks on this thread (even though it's older) for their various advice and expertise.

I picked up a FoodSaver at a thrift store - motor and vacuum worked, it just wouldn't seal. Thanks to the advice in this thread, I also narrowed down the problem to the pressure sensor switch. Had to un-solder it, and then open up the hex screw, but after cleaning the switch (q-tips & rubbing alcohol) my unit is working. YAY!

I would add that I wasn't super careful in noticing how far the hex screw was adjusted, so it took a couple tries to get it adjusted back to the right pressure.

tvandyke3 years ago
If you look closely in the pic with the motor (pump) & the green circuit board, there is a block. Easy fix, go to a pet store & get "fish pump air line", & replace that section, less than $1.

Check the red barrel connected to the brown side of the circuit board. This a sensor to vary the "pressure limit" before the sealing process is triggered. If anything is sucked into it, the sensor will not work. If you like small items, You can take it apart & clean it. Unscrew the hexagon screw. A small flat bladed screw driver, fits quite well. (& count turns until unscrewed, so you can put it back; exactly the way it was). Carefully remove the spring hidden inside. Inside is a metal plate mounted on a piece of rubber; (non-removable). Use a Q-tip & alcohol to clean the metal plate, let dry. Re-install spring & screw back in the hexagon screw; exactly the way it was.

I found that the pump piston (photos attached) is damaged (shards were still in the thin grease of the cylinder). Any idea where I might find a replacement? Looks like the end cap is replaceable by itself.

IMG_20160904_164820839[1].jpgIMG_20160904_164808610[1].jpg

I just want to thank you, tvandyke. Your instructions to canucksgirl on the pressure switch and how to clean it saved my Foodsaver v345 from certain demise. The pump was working great, but the unit wouldn't seal. After some Googling, I found this post and did what you said. PRESTO! Foodsaver is back in action.

The one thing you didn't mention but that I figured out from another website is you need to desolder the pressure valve off the circuit board to successfully remove the hex screw. But I needed an excuse to buy a soldering station (my first) and learn how to solder. Now what to do with it? I know! Time to build a drone!! :)

2015-01-10 22.02.42.jpg

I don't think the foam is a block. I think it prevents the tubing from collapsing under vacuum pressure. Mine has metal springs inside the tubing for certain tubes.

tyvandyke, thanks very much for the suggestion on the pressure limit switch. While the one on my sealer was glued and sealed, a little cleaning and cycling the switch by sucking on the tube got it working again.

MargaretF264 months ago

I have a FoodSaver v2840. The automatic vacuum and seal has stopped functioning properly. The bag is properly vacuumed, however, the machine doesn't stop at that point and move on to sealing the tightly vacuumed bag. It just continues vacuuming. I can hit the SEAL button, which stops the vacuuming and does seal the bag, but a bit of the tight vacuum seal is released. Any thoughts.

PenneyT17 months ago

my seal strip is not getting hot and the light is not on . it runs but no action.

If repairable, where can I get parts ...thank you

cl2iclcet7 months ago

good read. had a low suction on my food saver. took it a part just needed to be cleaned..

KimB1198 months ago

Just got a food saver for Christmas! Love it! TOok the drip tray out and shut the drawer..oops. Could not get that thing open to put the drip pan back in the drawer. starting taking screws out of the bottom and thought this is not good and a thought popped in my head plug it back in and turn it on...it unlocked the drawer.

zigernot9 months ago

TIME SAVER: I ended up taking a can of compressed air and disconnecting a couple of the tubes and spraying generously inside the unit. Plugged the unit back in and started sealing.

Thanks for all of the information.

godson19521 year ago

I HAVE THIS SEAL A MEAL Model VS 230 vacuum sealer,Well the problem is that it will NOT heat up to seal the end of the bag.Don't get me wrong but I'm assuming that the transformer is gave up its life ;)

canucksgirl (author)  godson19521 year ago

If it won't heat up to seal the bag, then you probably have a break in
the sealing strip. The good news is that's not terribly difficult to
fix. Just google "Foodsaver teflon sealing strip" to get parts and replacement
info.

Thanks ,will do that and will try that also.I know its a good machine and hate to part with it. ;)
canucksgirl (author)  godson19521 year ago

No problem. BTW, I did notice you said "Seal a Meal" and not Foodsaver, I just didn't type that correctly in my response. The same principles apply regardless of the brand. I also have a small handheld bag sealer and the sealing strip wire broke, but it was easy to diagnose and repair (using a wire from an old toaster) as its just sandwiched between a teflon strip and some heat resistant foam. ;)

I have a FoodSaver V845, it just won't come on at all?? Any help is greatly appreciated.

kayeyun1 year ago

I am having the same problem with my vacuum sealer (Model V475). I have located the vacuum limit sensor per tvandyke's instruction as shown in the attached picture. And trying to disassemble it to clean the limit sensor. But having trouble locating the "hexscrew". There is a small hole on the side of the sensor but there is no hex screw inside the hole. Could anyone show me how to disassemble the limit sensor? Thanks in advance.

Vacuum limit sensor.jpg
rickharris4 years ago
Ok the pump looks like a diaphragm pump. The diaphragm is made from rubber and may well have cracked or developed a hole - You need to inspect it by either removing or any other way you can check its integrity.

It may have valves or just simple flaps to control air flow.

I think the foam is to provide a small restriction in the flow so the pump sucks in the right direction i.e. out of the bag because that's the easiest direction for air to flow.

I would guess the foam is to prevent the tubing from collapsing under vacuum pressure. Mine has metal springs inside the tubing for certain tubes.

canucksgirl (author)  rickharris4 years ago
Thanks for the reply. I took the pump apart as far as I could (which wasn't very far). I don't see anything obviously wrong. I uploaded 3 new photos. I also checked the tubes and there doesn't seem to be any obvious cracks or holes.

Makes sense about the foam.
bajablue4 years ago
YAY for you and your now-functional Foodsaver! ;-D
canucksgirl (author)  bajablue4 years ago
LOL... thanks. I still don't know what was wrong, but it now works again!
rickharris4 years ago
The 2 cut away parts are the valves they fit over the inlet/outlet holes.

i agree with you and Steve something got in there and you scared it out.
canucksgirl (author)  rickharris4 years ago
I'm just glad it works now... Its probably the cheapest appliance repair ever! ;)

Thanks again for offering your help.
I wonder if one of the valves got stuck down with some juice accidently sucked into the mechanism ?
canucksgirl (author)  steveastrouk4 years ago
I'm usually pretty careful about sealing anything with liquids, but I suppose anything is possible. I figured you just scared it into submission, because after looking at it and reassembling the vacuum unit it started working again... weird, but I'll take a fix however I can get it. ;)

So a big THANK YOU to you!
Open it up and see whats going on. Whatever is used to hit the switch that activates the pump may have broken or the switch itself may be bad. You won't know till you open it up and see whats inside. When you do get it apart show us some more pictures of it.
canucksgirl (author)  mpilchfamily4 years ago
Thanks for the reply. New photos of the inside have been added.