How to remove an M42 Lens mount?

Hello,

I recently bought an adaptor for my Canon 600d ( rebel 3 ? ) to allow M42 lenses to fit to it.

That was fine but the adaptor is stuck on the camera.

It is not cross threaded.

I have tried using slip-jawed pliers really hard, but not as hard as I could because I was afraid of damaging something.

There is a small hole in the front of the adaptor if I press that and turn it , the adaptor separates, so I stopped that method.

Any advice ?

If not , I'll just go with the pliers as hard as I can.

Thanks



Picture of How to remove an M42 Lens mount?
IMG_1226.JPG
sort by: active | newest | oldest
petercd3 months ago

Brute force will most likely break off electrical connections inside the camera body.

I dont have these items, but a google seems to suggest that the dust cover on the inside of the adapter is catching on the camera internals.

Try pressing that front button to separate the mount and then wiggle the inside piece back and forth to disengage it.

Some folks suggested (google) to switch on the cam and take a few shots, switch it off and then try removing the adapter.

FriendOfHumanity (author)  petercd3 months ago

Hello,

Yes, I had read about the adaptor catching but I had not tried waggling it to disengage: I took a few shots first , I don't know if that helped, and waggled it for a few mins as I turned and it came off. . . thanks.

Thanks, great that all worked out.

I think you're right. The thread gets locked by the camera.

Jack A Lopez3 months ago

There is a small hole in the front of the adaptor if I press that and turn it , the adaptor separates, so I stopped that method.

This is a confusing statement. I thought you wanted to separate the adaptor from the camera.

To me, it looks like that button, "in the hole on the front of the adaptor", needs to be pushed down, so that the adaptor, the silver ring shaped thing, can rotate with respect to the body of the camera.

I noticed in the related panel, this 'ible,

https://www.instructables.com/id/Modify-a-Canon-EO...

has pictures of a similar camera, EOS-300, and similar "M42-EF mount adapter", and perhaps looking at those pictures could give you some insight into how your adapter works.

FriendOfHumanity (author)  Jack A Lopez3 months ago

Dear Jack A Lopez,

I have managed to remove it ( using the wiggling method - see above answer)

Sorry, yes the statement was confusing; I meant to say that when I pressed the ' hole ' and turned, the adaptor felt like its inner part was unscrewing from its visible outer part ( I was mistaken ) but regardless, it would only go so far before stopping. . . . if I tried it without pressing the hole it would not move at all.

Jeezo, even that sounds confusing,

As always, thank you for your detailed advice.

cheers

I am glad hear you were able to take it apart without breaking it. I think that is always good news, when a thing can be taken apart without breaking the pieces.