Instructables

How to repair autofocus on Nikon D40?

Hello - I have a Nikon D40 with two lenses. The auto-focus works on one lens, but not the other. Suggestions I've already tried are to clean the lens thoroughly and clean the contact points. I'm not sure if I cleaned the contact points correctly, and I'd really like to know if anyone else has had this problem and been able to fix it. Thanks!

jimjobe5 years ago
Have you by chance used the camera with Nikon's Camera Control software? I remember once using Camera Control to shoot some stop motion scenes, and the next time I went to use the camera without using CC autofocus wouldn't work. To fix it I reconnected to Camera Control and reset all the settings. Good luck!
brandegor (author)  jimjobe5 years ago
Huh - I have never heard of Nikon camera control software - can you tell me more about it? I unknowingly purchased the camera from the so-called "gray market" through one of those big dealers in New York, and when I contacted Nikon for support, there was none. Thanks for your help.
You can get a 30 day demo of the software on Nikon's support site. You just connect your camera via USB and run the software.
Joe Martin5 years ago
I've heard of this problem before but can't remember what the answer was, Doh! Rubbing alcohol on a cotton bud and rub rub over the cpu pins on the lens and body. Very silly but make sure it's on AF not M, do you know anyone with a nikon to try your lens on? You could try putting your working AF lens on, putting the camera on and then then swap the lenses over and then try.
brandegor (author)  Joe Martin5 years ago
Yes, I have it on AF - and of course I can use it with manual focus. What happens is that when it's on AF, and I press the shutter release, nothing happens. It isn't the camera, because the other lens works. I don't know anyone with a Nikon, or I'd try it. Thanks for your help.
ll.135 years ago
are you sure it's an auto-focus lens? The problem is probably not with the camera as the Nikon D40 doesn't have the autofocus motor on the body, instead the motor is in the lenses (thus only some lenses will work with autofocus on the D40) can you post a link or take a picture of the lens not working?
brandegor (author)  ll.135 years ago
Yes, it's an auto-focus lens - it worked when I got the camera. I'm not sure how I can take a picture of the lens not working - but if you can tell me how, I'd be happy to try.