loading

I HAVE A 83 JEEP CJ7 WITH 258 6CYL. STARTS GOOD RUNS GOOD AFTER IT WARMS UP. BUT WHEN FIRST STARTED IT WILL BEARLY RUN?

I HAVE CLEANED THE CARB. WHICH SOLVED THE HARD TO START PROBLEM. BUT NOW WHEN ITS COLD. THE START UP IS A ROUGH, SMOKING, SPUDDERING EVENT. UNTIL IT WARMS UP. ABOUT A MINUTE

Just_Joe7 years ago
The venerable 258 (4.2L) six banger suffered from chronic carb choke syndrome. Many had an automatic choke on it that was adjustable, but was VERY TOUCHY on the adjustment being spot on. After fiddling with that adjustment for several weeks, we then installed a manual pull chole and removed the automatic choke; that helped - some. After total frustration, we opted for the bullet-proof EFI system from Howell Injection that is designed for the GM 4.3L six. Problem totally solved and it starts immediately - hot or cold! And it will NOT stall upon stopping; many would stall out as if the thing had a high float setting in the carb. Know anyone who wants a BRAND NEW Carter OEM Carb for it? Used for 3 weeks on the '85 CJ-7 before finally opting for the EFI unit from Howell. Email us at Jowen28@nc.rr.com and make a decent offer - $50 or so. Good luck with whatever you choose to do!!
skunkbait7 years ago
DOes it have an automatic choke? It may not be operating properly. Also, I'd give the condeser a check. I had an old vehicle that behaved that way, and was just sure it was the carb/choke. $500 later, I found out it was a $5 condenser.
seandogue7 years ago
Have you replaced the cap/rotor assy? likely checked the spark plugs and wires? very possible Checked for a sticky EGR valve? (hmm..that one shouldn't go away though after warm up...or might it?) << possible but unlikely. leave it for the very last...