loading

I seemed to have pinched the wires to the screen when replacing it on my husbands laptop.

 I have a screen that comes up light blue but not working. Does anyone know which wire it might be??? It worked, but then I pinched the wires!!! OOOOPPs!?

sort by: active | newest | oldest
frollard7 years ago
Well, unfortunately if you've nicked the wires its likely you'll need a replacement - those fancy custom ribbon cables are very hard to repair. :(

If the screen comes on at all, the power wires are intact.
You mention a light blue - makes me think its a 'no signal' situation where one or more of the data lines are mucked up.  Check with the manufacturer to get a replacement cable.
**OR** take it apart again and make sure the cables are firmly in the connectors.  Sometimes they work loose as you reassemble.
Kriki (author)  frollard7 years ago
Thanks Frollard... I think I will check the cables once more, I had it all together...I THOUGHT...& it worked, then noticed I left the 2 screws @ bottom of monitor out, soooo, took it back apart & now this!!! What a touchy temperamental lil machine it is! lol
frollard Kriki7 years ago
carefully inspect the cables - they are REALLY finnicky!!!
My all means try this.  Those ribbon sockets are very finicky sometimes.  I used to have a laptop that I had to giggle a cable every six months or so to keep it working right.
lemonie7 years ago
We are going to need a bit more information here. What exactly have you done and do you have any pictures?

L