I want to adapt a 1341 solar engine to switch a 5v relay

SE output voltage switching motor at the moment is 2.4v .. how do i get it to 5v to switch a 5v relay ? - the aim is to use SE to trigger a relay that will supply voltage to an automatic car antenna motor that draws .7amps 7vdc, . The supply voltage for the antenna motor will be another separate supply, a 12v solar charged battery. My SE is using a 9v solar panel that gives out 109ma. thanks

sort by: active | newest | oldest
What IS a "1341 solar engine" ? Why not just use a 12V relay and a transistor turned on by your "solar engine" ?
carloc (author)  steveastrouk5 years ago
hi, ooops 1341 solar engine is in fact a 1381-solar engine using a 1381 voltage detector. image below... I have tried to replace the M motor with a transistor but as you can tell by my post am having no luck... my skills are lacking.. Not sure which transistor to use or where and how to hook it up.. any ideas.. thanks ..
SE_1381_basic.gif
Start from first principles.

What are you doing with the antenna ? When does it have to deploy ?

Lets work out what you want to do, and then work out how to do it.

Steve
carloc (author)  steveastrouk5 years ago
Hi Steve, all good questions .. I am still in development stage of this work but so far the basic idea is: 20 or so automatic car antennas will be buried in a small garden with their tips exposed. An array of solar panels 90w charging 90Ah battery will be used for power source. The antenna 'plants' will grow, up and down, during the day according to available sunlight. As to the frequency of ON/OFF switching etc and the choreography of the plant growth this will be decided once I can work out a decent reliable switching system. I was thinking that I could use solar engine to switch main load to antenna. By adjusting caps on and solar cell on SE i was hoping to adjust the timing of power on time. Once of course I have the antennas going up I need to switch polarity of antenna supply to send them down. I am bench testing at the moment and have a pleasant speed of up and down with supply voltage from my bench supply of 7v. Am switching a relay with 555 timer to reverse polarity to send it back down. Overall I was thinking that each hour the antennas would perform their growth up and down sequence about 20 times. My prototype antenna draws about 0.7amps up and down. So for 20 antennas one loop of up and down will draw about 14amps for about 20secs. So in an hour 94amps will be needed ?, which i guess is too much for my rated battery and solar array. I may have to shorten showtime... this is my first solar driven independent project and as you can tell not too sure about values etc of solar panels and batteries..what do you think.. thanks so much for listening..
No, you need a lot less power stored than you think. 14 A for 20 seconds is 0.07 AHr, you'll need quite a small battery. The "solar engine" would give you a nicely randommy effect, depending on ambient light etc etc.

Your reversal can be arranged at the same time.Forget the motor in the SE, put a relay in as I showed. When the relay is ON the antenna should go up, when its off, it should go down.

Steve
FY7ZX9PH0AR6YZO.MEDIUM.gif
carloc (author)  steveastrouk5 years ago
less power great ... however just tried small 12v relay set up but it failed to switch. Attached wire from SE to one pole of relay coil, other relay pole to +12v seperate supply via diode no joy...SE is working, been testing with small motor. what am i doing wrong.. thanks
You DID connect the -ve terminal of the panel to the 12V battery -ve didn't you ?
carloc (author)  steveastrouk5 years ago
hmmm .. yes I did and that and it worked .. yipppeeee but then just as a test I pulled out the +ve pole of solar panel and the circuit still worked as the cap was filling via the battery ? --- have i misunderstood the diagram... the diode goes between signal from SE and battery 12v +ve and the ground from battery connects to ground of solar panel..
It will take as long as it take the capacitor to discharge to switch off ! Put a MUCH smaller cap in now, because the only thing sucking out energy is the base current in the transistors.
carloc (author)  steveastrouk5 years ago
it was switching nicely, every 10 secs on for 2 secs then off again .. but when i detached th solar panel +ve wire it behaved the same.... so i concluded that the solar panel was no longer charging the cap but the battery was .. I tried an alternative set up with solar panel and cap parallel to it.. and this worked of course one time but then even with a zener diode in the circuit it would not switch off and fully charge cap again .. but i guess i am just demonstrating my lack of electronic logic..
thanks for your patience ..
OK, try this one then. I've isolated the SE from the rest of the circuit with an optoisolator - they're cheap enough to use here. The LED will present a nice load to the SE as well.

There's no way this one can back feed.
FY7ZX9PH0AR6YZO.SMALL.gif
carloc (author)  steveastrouk5 years ago
hi ... tried the above and various variations of it but still no luck .. relay stays on .. no switching.. i have been breadboarding and the SE on its own triggers the a small motor at 2.2v, the 1381s i have should trigger at 4.0-4.3v according to a chart.. so bit confused there and wondering if low trigger voltage is failing the circuit... here a sketch of what i understand the wiring should be... I have used a BPW 14 optotransistor that i had lying around.. perhaps this is faulty... for LED i used a green LED then replaced it with a photodiode. can u recommend an opto transistor ? ...
Picture 1 copy.jpg
There shouldn't be ANY electrical connection from the SE to the relay - that's why I said use an opto-isolator.

Where are you in the world, for me to recommend parts sources ?

Steve
carloc (author)  steveastrouk5 years ago
Hi there .. I am in Berlin Germany... we have Conrad here for parts which is not bad or I can order on-line from a few other sources .. thanks Steve ...
Try something like a H11A1 optoisolator then.

Steve
carloc (author)  steveastrouk5 years ago
ok got one on order .. well something similar .. CNX 83A .. will let you know how i get on ... thanks ..
You'll have to add another transistor to allow it to switch a relay.

Steve
carloc (author)  steveastrouk5 years ago
oh .. why .. sorry i thought the optotransistor did this ..
Check the current that the relay draws. I suspect it will be more than 50mA.

Steve
carloc (author)  steveastrouk5 years ago
hey ho .. it works .. thanks Steve .. moving on to stage 2 now ... figuring out my solar system..and ordering off ebay lots of car antennas ----
Don't forget to Best answer this question then !
And I'd love to see some finished pictures.
Steve
carloc (author)  steveastrouk5 years ago
Best answer .. hmm sorry new to this forum .. ok .. hmmm .. where is the Best answer button .. pictures for sure once installed .. thanks again .. now working with an arduino for some precise puppetering ...Cc
Right at the very top, in the box with my first answer, is a button marked "Best Answer"

You could take this a long way, if you have the arduino too - add a light sensor and you could make some flowers come up at different times to others.

Steve