loading

IDE hard drive wont spin up in external array, using hacked power supply.....?

           So after building my new computer I had three old IDE 250gb and two 40gb hard drives.  I took some scrap aluminum and built a rack to mount the drives on. I hacked an old power supply and made a power supply for the drives. I bought 4 IDE to USB connectors and ran then into a USB hub. For some reason the power supply turns it self off a few seconds after plugging in the 250's. It will run the 40's no problem and the system instantly recognizes them.  The jumpers are all set to slave. When I individually try them with my single IDE to USB kit they work fine.
400w for just 5 drives should be more than enough power.

Please help me out.

Specs.
Power Supply
Antec-PA-412x 400W

drives-250's
WD2500-WD Caviar SE
WD2500-WD Caviar
Seagate Baracuda 7200.8

drives- 40's
IBM Deskstar 40
WD400- WD Caviar
 


Picture of IDE hard drive wont spin up in external array, using hacked power supply.....?
IMAG0140.jpg
IMAG0141.jpg
IMAG0142.jpg
sort by: active | newest | oldest
zack2476 years ago
like vyger said below, this psu may not be very healthy anymore, ive seen 550W antec PSUs blow up just from daily use, IMHO antec PSUs are of a really low quality, but thats just me, i choose to avoid them whenever possible.

looking at it, there looks to be a ground wire running to the hard drive stack's chassis, this could also be a problem, some hard drives have circuits in them that prefer to be separate from other hard drives.
G-MAN75 (author)  zack2476 years ago
I added that jumper last night to try something new it doesn't affect it either way.
I tested the PSU and it works fine, but ill look for another PSU..

thanks G-man
If the power supply is being overloaded in any way, there may be a "resettable" fuse blowing or tripping, that resets once it cools down. As Pranavsharma says, getting them to fire up sequencially may be the ticket here.
pro2xy6 years ago
Try using delayed spin-up on one 40gig and one 250gig...
Its a small jumper setting on the hard drives, check the manuals for that..
This should allow the drives to fire up a little more sequencially, letting the power supply have a little breath.......
frollard6 years ago
Your mechanical junction in the wires mighe be the problem - are all the connections soldered? Just twisting together might not allow enough juice to the end of the daisy chain.

You can get psu molex connectors that hook up to bare wire and pull their individual power, then you can run one vertical set of connectors on one set of wires.

Agreed with others having them all spin up at the same time can be pretty hard on the psu.

Does it work if you slowly plug the drives in one at a time?
**try plugging them into power, but not the usb.

The psu might be seeing a short/ground loop between the psu ground and the usb ground
G-MAN75 (author)  frollard6 years ago
Well after trying a couple things, i got on drive to say on for about 15 sec, i tricked it by switching the PSU on and off as soon as it tried to shut off, but then it shut down. I unplugged at the usb adapters, iam not running the daisy chain adapter, just the molex from the PSU.
...and the power supply still shuts down with only the molex adapters being used?
G-MAN75 (author)  frollard6 years ago
All the connections are soldered. just wrapped up for protection. Ive tried every configuration in the daisy chain of molex connections. Ive tried plugging them in one after each other but its no good, as soon as I plug it in, the PSU turns off.

Ive tried flipping the power switch to trick the drive into spinning up. The sound it makes is weird, the drive doesn't seem to initializes and spin, and the PSU just kinda shuts off.


G-MAN75 (author) 6 years ago
See i thought it could be a short somewhere. But ive checked it twice. The supply can give alot of current no problem, tested it with a variable load resistor and one of my schools good FLUKE multi-meter, each drive shouldn't need more than 1A, so even at 12v the supply still has 18ish amps. Its weird how the 2 40's spin up and run no-problem... I was thinking it was a chassis group problem but even after adding a jumper to the drive it still wont work?

Iam out of ideas, I added resistors on the 5v and 3.3 v circuit, iam gona try moving the 3.3v resistor to the 12v terminal, maybe it needs to since a load before the drive will spin up?
G-MAN75 (author)  G-MAN756 years ago
Changing the resistor did nothing.
I just wonder if the PSU can spin them all up, from rest, and cold.

Steve
Its possible that the PS could be weak or near failure, but before I jump on that I would look at the wiring.
I used to routinely run multiple drives in a system. I had 2 raid arrays each with 2 drives. And then would add on another drive to transfer stuff to. It ran fine on a 450 Watt PS. So it should be able to handle it. But it could be failing. I would still look to other causes first because a PS almost always just quits, sometimes with a bang.
In a proper raid, do they not sequence the spin up ?
Nope, at least mine never do. Its just everything on all at one time, fans, components, drives, all at once. That's usually when the power supplies blow. I have people tell me they just started it up and there was a pop and it died. (caps blow)
Anyway the drives have to be spun up and responding before the raid controller queries them otherwise it will declare the array as having a problem and will try to start rebuilding it.
Vyger6 years ago
Yes the power supply should have plenty of juice to run them. Even a 200 watt one would be ample.
This may sound silly but double check the polarity. You might have gotten one of the wires reversed so that as soon as you plug it in it overloads the PS. Its an ambitious project. I have thought of doing something like this myself. I bought a bunch of removable drive bay inserts and was going to convert them to USB. Anyway, it sounds like your crossing wires somewhere, Put all the positive's on one main line. The worst thing with a project like this is having to tear it apart to find the problem after you seal and or tape it all up. I have learned to do a test setup first and after I am sure it works to do the final connections.