loading

IS this circuit with PICAXE18-M2 driving a Motor correct ?

IS this circuit with PICAXE18-M2 driving a Motor  correct ?

Im not sure if im doing this correctly, i went off an example. im trying to get the motor to go forward and reverse.

Chips used:
PICAXE18-M2 - http://www.picaxe.com/docs/picaxe_manual1.pdf
SN754410NE- http://www.ti.com/lit/ds/symlink/sn754410.pdf
MC7806CT- http://pdf1.alldatasheet.com/datasheet-pdf/view/355548/MCC/MC7806CT-BP.html
LM340T5- http://www.alldatasheet.com/datasheet-pdf/pdf/8589/NSC/LM304.html

i have attached the schematic and code below. if some one can please help me find out what i did wrong. thanks

Code from PICAXE Program Editor

symbol MF = B.4 ; rename output4 `MF- Motor Output Forward’
symbol MR = B.2 ; rename output4 `MR- Motor Output Reverse’
main: ; make a label called `main’
high MF ; `MF- Motor Output Forward’ on
pause 250 ; wait (250 ms)
low MF ; `MO- Motor Output’ off
pause 250 ; wait (250 ms)
high MR ; `MF- Motor Output Reverse’ on
pause 250 ; wait (250 ms)
low MR ; `MO- Motor Output’ off
pause 250 ; wait (250 ms)
goto main ; jump back to the start

Picture of IS this circuit with PICAXE18-M2 driving a Motor  correct ?
photo 2 redo.JPG
iceng5 years ago
You could rotate your pics before uploading
picax.jpg
rickharris5 years ago
Your diagram looks OK - according to the SN754410 data sheet.

You should use the download cct attached to the serial in or funny things happen if you let it float - There should be a 10K resistor in there.

Again your FAR better off asking the Picaxe Forum these questions they are ALL experts in helping.
dudeitskumar (author)  rickharris5 years ago
thank you, i did ask the forum, i thought i would put it up here as well. waiting for answer there. :) thanks again