loading

ITS URGENT! Arduino not working with external power supply?

I have made arduino uno u3 robot, i have used 2 geared motors via a l293d using one 9v battery and tried power the arduino with a 9v battery, then with 9v adapter but it did'nt work, I also tried powering the board via the Vin pin, also through the usb cable using the 9v batterg and adapter, but it didnt work either.when i plug it to the laptop with usb everything works very fine. Please give me a sol. soon urgent i hav the exhibition after 3 days!!

sort by: active | newest | oldest

So the UNO is still working on USB ?

a 9V battery isn't likely to run the thing, and the motors.

What did you use for the 9V adapter ?

Show your circuits.

Steve

Ankan Nayak (author)  steveastrouk2 years ago
it only and only works when i connect the board to the pc via usb cable.
if i try to power it with a battery through the usb jack, it doesnot work.
the adapter is simply a regulated 9v supply from a rectifier.
the motors are connected from l293d, with 6v regulated power.(on bread board)
the servo is connected on the breadboard.
i have made the ground common for all..


plsssss....suggest me something...

instrctables is not letting me upload a pic..sry.

Can't help without a diagram, sorry.

DON'T POWER IT THROUGH THE USB JACK !!! Not with a 9V supply !!!!!

RJK6 steveastrouk8 months ago

I have same problem as Ankan but with 6V instead of 9.
I made a arduino car robot with arduino uno (shields on it), sharp IR-sensor, 2DC motors, 4AA battry and 2 limited switch.

When I connect the arduino with the cable, it works fine! all the functions work and I don't see any errors. However once I try to let it work through external power supply (4aa) it doesn't work at all. The power light lights up but that's it. I think I would need to use resistor for each limited switch but I have no clue which resistors I should use and I am not certain if it will solve this problem either. Please help me because I am getting so hopeless. Thank in advance.

PS - I tried this method but it seems like it's not working at all
V = R * I, or solved for R, R = V / I
R = 6 volts / 0.030 amps
R = 200 ohms --> 220 resistor

my breadboard are based on this fritzing sketch (the code is made by me and it works without a problem)
https://killerrobotics.files.wordpress.com/2015/06/robot-part-1_bb.png
https://killerrobotics.files.wordpress.com/2015/06/robot-part-2_bb.png

steveastrouk RJK68 months ago

Show me a circuit diagram, not a pretty picture. The usual problem is missing a ground somewhere.

I have noticed same with my nano V3. The sketch works perfectly when it is connected through usb by pc or using a mobile charger adapter with USB connection.

As soon as i power it using Vin pin and ground with regulated 12V supply or even a 9V battery, it works crazy i.e. the sketch is not running at all.

As soon as i again power is through USB jack, it works perfectly.

this is very strange... any clues.. suggestions ?

I have the same problem, please help me with the solution!

I had make mistake in wiring as mentioned in my earlier post.

Just check...sometimes we very simple mistake due to oversight.

I solved the problem.

i noticed that by mistake i had connected a resistor between ground pin of my nano and ground of my powersupply.

i removed it and now it works perfectly.

rickharris2 years ago

Just a small point - The 293 will only power small motors - about 800MA then it automatically cuts off. This gives the appearance that it isn't working.

I aghree with the others as well.

That fact alone is likely to kill his 9V battery. "For the want of the nail"

Pazzerz2 years ago

An Arduino Uno can be powered by

  • a stable (regulated) 5V DC, which you can either supply via the USB power lines, or via the shield connectors, or
  • an unregulated 6-20 V DC (7-12V recommended), which you can supply via the 2.1 mm centre-positive barrel plug connector.

I would not recommend using a 9V battery, because its voltage will drop quickly, but in a pinch this can be used.

ref: http://arduino.cc/en/Main/ArduinoBoardUno

Absolutely, and there is very little chance the 9V battery will run motors anyway.