Infrared Sauna wiring?

Well, I bought a used infrared sauna the other day for real cheap because it "just stopped working all at once". Figuring its just a fuse or something, I took it. Well now I cant figure it out for the life of me.What seems to be the problem is that no power is getting to the primary transformer. That would be on the second small circuit board to the right. It is getting to the secondary transformer fine. Heres a pic of whats goin on. Those things on the sides are fuse holders, (no not burnt out).

Picture of Infrared Sauna wiring?
sort by: active | newest | oldest
SunsetS12 years ago

OK, well to start with, I see that this was posted approximately 3
years ago... so perhaps I cannot help the original poster of this.

To
determine whether it is the main board or not, based upon the picture
above, first unplug from the wall. Next, move the left two wires (BLUE
AND BROWN) to piggy back the right two, making sure to keep the brown
together. It probably won't matter if you get them mixed up since they
are AC, but maintaining the color code is a wise practice. Plug back
into the wall.

If the sauna comes to life again, the problem is the main control board.

If
the sauna remains dead, it is the 12v DC power inverter board which is in the top
right of the picture and is incorrectly labeled "Primary Transformer
Board."

That said, the problem with this style of control system is most likely the main circuit board itself.

Our company has been rebuilding infrared sauna control systems for the big
retailers and dealers for more than seven years, and the failure in this
post is a really common one.

We offer a customized DIY repair kit, or you can ship the whole unit to us for a professional rebuild.

We rebuild these all the time, and our 5 yr. warranty is the best in the industry.

Feel free to contact us at: sunsetspas@gmail.com

Or call our office at: 660-263-0984

Ask for John.

Not sure why the text formatting in the above post is screwy... it was right the three times I reposted it to try to correct that issue.

canucksgirl5 years ago
We use saunas in our family (we're all originally from Finland), but we don't have infrared saunas... I showed a family member your question, (they've told me to tell you to), test the thick red primary wire (on the right), by using another one from board to board, to see if thats the issue. If that still doesn't get power moving, then you may have a problem with the power board itself. He said to then remove it and check it for any obvious signs of a problem. If the new wire gets power flowing to the primary board, but the unit still fails, then the primary could be the issue, or another problem could exist on that board. You'd need to then remove it and look for signs of any problems.

I hope that helps. (Sorry for the 3rd party message). :)
LiquidLightning (author)  canucksgirl5 years ago
Right, forgot to mention that the green blocks are the output power from transformers, not input. The blue brown brown red are the input power.
Hopefully you can detach the boards and get photos from the underside... there's plenty of members here willing to help. :)
rickharris5 years ago
Test continuity of the cable in from the mains. Go from Plug to terminal on transformer. If no continuity the work back to find the break.

Don't assume the plug is OK.

LiquidLightning (author)  rickharris5 years ago
Which plug? From the wall AC power?
Yes the AC plug. This way you know if the electricity is getting to the board or can isolate why not.
iceng5 years ago
What you call the primary appears to be a AC to DC converter module
the red and black wires are output DC.
Reading between your lines, one of the converter driving power
switching transistors has failed.
The lower circuit which we can not see may have useful info to help
your cause.

A
LiquidLightning (author)  iceng5 years ago
Gotcha, i'll get pics in a bit. You are correct about the black/red. Those should output 12v DC, but they output 0. That is the whole problem, either that module failed, or power is not getting to it.