Laptop wifi?

Whenever I turn my dell vostro 1500 on, sometimes the wifi works and sometimes not. At the startup, the wifi light turns on. Even if it isn't connected to anything. I have checked the wifi capability switch on the side and the 'diagnose and repair' is useless. I am using windows vista. Thanks for any solutions.

frollard6 years ago
That sounds to me like a bad driver installation: What causes it? Nobody knows -- something gets corrupted and it goes south.

What can you do about it?

Uninstall and reinstall the hardware drivers, trying newer (or perhaps older) driver versions if the same version doesn't work still)

In device manager (search it in control panel) -- right click and choose to uninstall drivers for your wireless card. If it still shows up in the list, right click and 'remove hardware'. Then scan for hardware, and it'll say "you have a network card, install drivers' -etc.
Reinstall drivers from the disk for your computer, or download them from the manufacturer's website.

If the above doesn't work, consider trying a new wireless card, yours may be pooched, or even simply loose in the connector - pop the bottom off your laptop with a screwdriver and make sure the connections are all solid. A replacement will only be 20 dollars for no-name, upwards of 100 for branded fancy ones. Buy from a computer shop with a no-hassle return policy in case it's neither the drivers or the hardware, but worse, your computer's fault.
acidbass6 years ago
a bad radio could be the prob happened to me