loading

LilyPad Port?

Help!! Having the hardest time getting lilypad to talk to my Mac. Arduino IDE can see the board (both LilyPad and LilyPad USB), but I have only one port listed which is different then the one(s) shown in this tutorial. The sketch obviously compiles but I cant upload to the board. Any tips to troubleshoot?


bekathwia3 months ago

When the board is in the list, it just means the IDE supports that board, not that it can "see" your board. That's the ports list-- what ports your software sees. First thing's first, is your board switched to "ON"? Then: Try swapping your USB cable, switching to a different USB port, using a USB hub (or not using one if you were), restarting your computer, trying on a different computer with all the previous things... then check out the arduino troubleshooting page for more things to try: https://www.arduino.cc/en/Guide/Troubleshooting

Tedwardsmvps (author)  bekathwia3 months ago

Thanks for the response. Took a while to troubleshoot...tried new wires, new computer, etc. Turns out that there must have been something defective with the board. I plugged in a new board and things worked just fine.

Note to self and the community: Test the board BEFORE sewing on buttons or wires!