Mach3 not following code?

I am trying to mill PCBs, but when i do so, some traces vanish because the cnc moves along the same y-coordinate twice instead of leaving a trace. its always the same traces and only some of them. Does anyone know what's going on?

sort by: active | newest | oldest

There are a fair-few free Gcode viewers which will simulate the toolpath - Mach has one built in. Can you see it go wrong on the Mach interface ?

jg156 (author)  steveastrouk3 years ago
Hi! Thank you for answering.
It is not wrong on the interface. I even manually went through each line of code, and it does point to two separate locations. But, it does always occur at the same places in any given gcode file.

Is this a DIY mill, or a professional one ? If its DIY, and its stepper based, is it possible the action is sticking in "that" spot, and missing steps ?

jg156 (author)  steveastrouk3 years ago

It is a DIY. Might be the problem...

What is a good way to check?

I tried just jogging between the two y-coordinates and it was fine.

How about a test rectangle, with the long edges being the Y axis, and step the rectangle across the problem area ?

jg156 (author)  steveastrouk3 years ago

Ok. Did that. The rectangle comes out fine.

Stepped across on the minimum step size ?

jg156 (author)  steveastrouk3 years ago

What do you mean?

cut rectangle: Move over 0.1mm, cut rectangle, move 0.1mm..

jg156 (author)  steveastrouk3 years ago

Ok. I did that too, looks fine.

I want to add that im using PCBGcode to generate the Gcode. I didn't think it was the issue, since the Gcode, the DRO, and the toolpath all look fine, but when i tried to use it to do a similar drawing (lots of rectangles) a bunch of them came out messed up in the y (though gcode, DRO and toolpath were all 100%.

I still don't want to believe its the generator's fault, since the toolpath, DRO are fine, and when i manually jog to the coordinates, also fine...

Gcode is a text file and so can be read in Note book or a suitable word processing prog. However it doesn't have line feeds or CR so is a block of text.

The word processor can easily replace the ; with l fcr

jg156 (author)  rickharris3 years ago

Yes, but both the toolpath and the DRO in mach3 look fine

rickharris3 years ago

Very often when a track gets a double visit it is because you put 2 tracks over each other. easy to miss and often happens when a CAD picture gets a copy past action.

Check the system with a VERY simple drawing squares, lines and make sure they are all single lines. If this workes your almost certainly puting down double tracks - Mach 3 has too many users for such an obvious faut not to be noticed.

jg156 (author)  rickharris3 years ago

Thank you for your reply.

I just checked, and with simple figures, it works fine. I don't think it's a double track problem. It looks fine in the interface and when loaded to Lcam. Also, it not only draws one line twice, but also skips the line on the other side.

The problem does not seem to be with the gcode: two different lines are virtually drawn. For some reason, when a line with y coordinate .63, for example, is drawn by the machine at .55. What makes me think its the software and not hardware is the fact that its always the same place in a given piece of gcode, and it doesn't happen in every similar scenario.

If the system can cope with simple figures hat cover the same physical area then something is wrong with the drawing - as I said there are far too many Mach 3 users out there for this to have gone unnoticed.

I suggest you slowly build up the complexity of your drawing until you repeat the fault - or not -

The other option is to closely inspect you initial drawing in the faulty area to see f there is a double track or similar drawn.

IF the error occurs in the G code it is happening either in the conversion OR the drawing phase. the Mach 3 is just following the G code.

If the fault isvisible in the Gcode then there isn't an issue with the hardware sticking either.

iceng3 years ago

Sounds like a software conversion glitch.

Try talking to the people who supply the mill software.

jg156 (author)  iceng3 years ago

Its Mach3. From my experience, they are a little hard to get to, but I think i'll try contacting them. Can't hurt.

Thanks for the suggestion!

How thin are you making these traces and what's the accuracy of the mill?

jg156 (author)  mpilchfamily3 years ago

Not the problem. Traces are mighty thick, also not all of them have this glitch.

And the ones that do are all horizontal tracks (bug is in the y-axis,) though not all horizontal tracks have the bug.

Thank you for your response.