Instructables

My left side of my speaker system won't work and I dont know what is wrong?

Well a couple weeks ago I was driving. Before that I put in a Alpine 2-way speaker in the front left door of my car. I drove one day and I think it came loose and popped out. I was parked but had the car on and opened up the door. I closed it and all noise cut out. Seconds after I smelled a burnt smell. I assumed I fried my speaker so I left everything alone for a couple days. I thought the speaker got some water on it or touched another metal surface. But I cannot tell what happened. So then I got some info of what I should do and I took out my aftermarket radio, replaced the fuse, and reset it. So now only my 3x9 Kenwood speaker on the right in the back works. I tested my Alpine 2-way speaker on each side of my car and it worked, but only on the right side. So all my speakers work, but wont work on the left side for some reason. I was hoping to find out what happened because I have no clue if I should go in and replace wires. I made sure that everything is connected and it is. I think I blew the connection on the left side but I dont know. I have a 96 Honda accord. If anyone can give me feedback, please do so!

framistan4 years ago
If the wires to any speaker are SHORTED to each other... you will burnout the amplifier that feeds that side.  If you connect another stereo to the SHORTED wires... you will burn out the new stereo also.  If the wire is OPEN... (just disconnected)... then no damage will occur to the amplifier.  Heres how to test all your wiring and speakers with a 9volt battery and a couple wires.  Just remove your stereo from the dash.  Unplug the connector that feeds the speakers.  Use your little 9volt battery to send volts to each speaker ONE AT A TIME.  You should be able to get each speaker to give a CLICK CLICK sound when you connect the battery to that speakers wires.  If any speaker FAILS to give the click sound... then you must investigate the wires and the speaker that is failing to respond.   If you discover your wire was broken (open)... then just re-connecting it (and electrical taping it) will fix everything.  If the wire was shorted (touching each other)  then you will likely need to fix or replace your stereo unit. 
Modern amps SHOULD just shut down in a short circuit, the fact a channels "blown" IS odd.
frollard4 years ago
I'm guessing the output driver in the internal amplifier is cooked (thats the magic smoke you smelled).  Double check all the wiring and that there are no shorts/opens.

Test with another stereo head if you have one.
Paralytic (author)  frollard4 years ago
I just tested my speakers with my honda stock headunit and everything works. I believe I cooked the internal amplifier, since i can only hear the right side of it. Could my JVC headunit be fixed?
Maybe under warranty return, but my guess is the head unit's goose is cooked for all but electronics engineers with too much spare time...
+1, or -1 IYSWIM
-1 makes frollard sad.
+1 for a good point, -1 for a sad answer :-(