loading

Need urgent help in H-bridge!!

Hi,
     I am building a H-bridge to drive my robot's motors. I am using the circuit from the following link http://wiki.mech.uwa.edu.au/index.php/Micro_crash_course/pwm#P-channel_FET     (Figure 12). For the mosfets I have used IRF540 and IRF9540. The moment I connect this circuit to my 12v power supply, the IRF9540, heats up very quickly although I have not connected it to any load !  For logic input, I am using the Arduino. Please help me with this H-Bridge circuit. Thanks in advance.

sort by: active | newest | oldest
iceng5 years ago
You are using MOSFETs in a Junction FET circuit design only good for 5 VDC
that is why fig_12 is VCC powered.
The legs of your H are shorting the supply ie both turning on at the same time.

There is a lot you need to know to make this work.

Here is one that should work 4 U...   .   .   .   A

H-Bridge-MOSFETs.gif
Jayvis Vineet Gonsalves (author)  iceng5 years ago
Thanks a ton iceng. Could you please me the input truth table for this ?
If I cannot get the irfz40 and the irf930 then can I use irf540 and the irf9540 instead?
iceng5 years ago
  • | A | B | C | D |
  • ------------------
  • | H | L | L | H |   REV
  • | L | L  | L | L |   OFF SPIN [TRANSITION]
  • | L | H | H | L |   FWD
  • | L | L  | L | L |   OFF SPIN [TRANSITION]
  • | L | H | H | L |   FWD
  • | L | L  | H | L |   OFF SPIN [TRANSITION]
  • | H | L | H | L |   DYNO BRAKE
  • | H | L | L | H |   REV
  • | L | L | L  | H |   OFF SPIN [TRANSITION]
  • | L | H | L | H |   DYNO BRAKE
  • | L | L  | L | L |   OFF
  • | H | H | L | L |    Death, Damage, Disaster
  • | L | L | H | H |    Death, Damage, Disaster
  • | H | H | H | H |   Double, Death, Damage, Disaster
Yes, this design is substitute device tolerant.
Hello iceng, as I see you have lots of knowledge about electronics and h-bridges.
I built the h-bridge according to the schematic above but am having problems when using PWM to drive the motors.
Here's the link to my instructables question:
https://www.instructables.com/answers/Need-help-with-MOSFET-h-bridge-gets-hot-when-usin/

Could you help me?

Andy
Thanks a lot for the shematic and the truth table! I've been looking high and low for a shematic of a working MOSFET h-bridge using IRF540s and IRF 9540s!
Thanks!
Jayvis Vineet Gonsalves (author)  iceng5 years ago
Thank you iceng.
vkarpuram5 years ago
I've tried the same schematic withe irf 540n and irf 9540n, but cannot get it to work, especially the p - channel mosfet.

Please help
iceng vkarpuram5 years ago
First I assume you are running 12 VDC with a true 5VDC = High.

The IRF540 will conduct only 8 amperes at a 5V gate see the fig.

If you are using a lower power voltage the P MosFet may not turn on.

A
gate540.pngGATE9540.png
vkarpuram iceng5 years ago
Yes i am running it on 12 volts DC, and supplying the signal from an arduino mega 2560. I could not get the p mosfet to turn on at all. Could you please post a schematic for the P- Mosfet. I am using a 12 volts lead acid battery (7Amps).
iceng vkarpuram5 years ago
Follow the numerals,
  1. I short the gate to ground making sure that fet is OFF
  2. activate the BC547 High
  3. iI measure the voltage from +12 to the gate 9 or 10Volts would be great
  4. 5 or 6 volts acceptable
  5. the P FET should be ON
  6. if not then III what is the voltage across the BC547 should be under 2volts
  7. if not again try changing the base drive resistor to 2200 ohms and repeat from step 2...
A
ckt.JPG
lemonie5 years ago
We can't see it; picture / diagram of what you built please.

L
Open the link
http://wiki.mech.uwa.edu.au/index.php/Micro_crash_course/pwm#P-channel_FET

see figure 12. I have followed the schematic and replaced the VP2110 with IRF9540 and the BS170 with IRF540.
iceng seems to know what you need already.

L
Yes he has given me the circuit for the H-Bridge. Also thank you lemonie!!