Pioneer Stereo Receiver MODEL SX-525 keeps blowing 2amp fuse?

This pioneer receiver has been working for the last 30+ years.  I was using it in my wood shop and went to change the station, I spun the knob to go to a higher station and then the sound cut out and then the receiver turned off.  I then found that it blew the 2 amp fuse (the singled out one of the three used).  I replaced it and turned it on, the lights came on and the speakers put out a law *boooooooo* (low tone) and then the fuse blew again (about 3-5 seconds).   I am not great at diagnosing electrical issues but can replace something if instructed what needs to be replaced.  Please help.             Thank you.

framistan4 years ago
Most likely, something has shorted. Since the unit is old, you should suspect the LARGE electrlytic capacitors because they are 30 years old. .. Or possibly, the rectifier diode section may be shorted. Also, possibly one of your final amplifier transistors may be shorted. The diodes (or bridge rectifier) can be checked without unsoldering them usually. If the diodes have forward resistance of around several hundred ohms then they are ok (check all of them, usually there are 4). Also the output power transistors can be checked without unsoldering usually. If any item tests "NOT-SHORTED" they are probably (but not certainly) OK. If they test "shorted" then you must remove it from the circuit and test it again. If it still tests SHORTED, then it IS bad and must be replaced. The best procedure is to test each thing ONE AT A TIME. Then put it back like it was and move on to the next suspected part. This way, you will not make a mess of it by taking a bunch of stuff out and don't know where it goes back. Be sure you follow safety procedures because of high amperes and voltages in those areas of the stereo. If those items pass the tests and are OK, then it's time to get out the schematic and do some serious troubleshooting. I own an old pioneer SX-828 and they were nice systems. Hope you get it back up running again.
I've found the schematic, its not going to be easy to find the fault, without a large selection of fuses.

Try isolating the various boards inside, and seeing if you can stop the fuse blowing. Once you have isolated which card it is, then we can find out how to fix it.
I just fixed a fuse blow issue on my pinball machine - turns out one of the mosfets that drive a bumper was fried - without a HUGE amount of 'unplug everything then find when it blows' its very difficult to actually determine what the problem could be.