Problems Jailbreaking and Unlocking Original iPhone?

I have an original iPhone that I want to unlock for use with T-Mobile, as well as jailbreak.  I have tried multiple jailbreaking/unlocking tools, and when I point them to the IPSW for the iPhone I always get some version of:  "This is not a valid 4.0 IPSW."  Sn0wbreeze's "F0recast" program says that the phone is jailbreakable and unlockable, and that it's running 3.1.3 firmware.  I believe it's been updated to iOS 4.0---I put it into recovery mode and connected it to iTunes, and it updated it.  I do not have an AT&T SIM card.  Anybody know what to do? 

Bernita862 years ago

Factory iphone unlocking service like this one will help you easily.

TheFawns7 years ago
if you are using an original iphone, apple has already ended support for the 4.0 ipsw for that device. if it was any other iphone then you could upgrade to 4.0 so that could be your problem right there