loading

Quadcopter wont lift off?

I have made a quadcopter. However, it wont lift off :( I really need help with that.

Following is the list of components I have used:

1) http://www.buildyourowndrone.co.uk/QuadCopter-Full-Motor-ESC-Set-850Kv-p/acq-fmk85.htm

2) 6200mAh, 35C LIPO battery

3) http://www.buildyourowndrone.co.uk/ArduCopter-QuadCopter-v1-0-Frame-Carbon-Fiber-p/ac-frcarbon.htm

The weight of the whole copter along with the battery and the components is 1.52Kg which I am sure the motors can lift. I am using and arduino UNO and an MPU 6050 along with a FLYSKY 6Channel Rx/Tx for communication.

The motors run on full power, however I am not sure why I can not generate a lift :/ I really need to make it work as this is my final year project. PLeaseeee someone help me :(

sort by: active | newest | oldest
rickharris3 years ago

Put the quad on a set of scales. Run up the motors and see if the weight drops - if not:

1. Your not generating lift - props wrong,or motors not powerful enough or not reaching full speed.

2. Your not generating enough lift - i.e. the weight loss show is less than the weight of the quad. - See above for motors - props wrong pitch - weight too high.

3. Battery too heavy

Bam Boy (author)  rickharris3 years ago

yeah I think its a good idea to check the thrust. I shall try to do it on the set scale and see if I get any positive results.

Hello I recently bought LS124 quadcopter but it does not takeoff and one of the rotors hardly turn any solution to that?? Please help me and if you can contact me with solution will be really sweet on rahadwalamohmedaadil@gmail.com

It is an electrical problem... What are your electrical skills ?

Be thorough...

https://www.youtube.com/watch?v=jB75SrvfzgY

ZoeD171 month ago

hello guys! I am building a quadcopter and I used this instructable:

https://www.instructables.com/id/The-Ultimate-PVC-...

It won't lift off at full throttle, it weighs 3.2 pounds with the battery,

I am using 10" propellers, 980kv motors, and 20a escs, the motors are all spinning in th right direction and have the right propellers on too.

Can some one please help me this is my first drone, I've ever built/owned. :)

Bam Boy (author) 3 years ago

I have fixed the problem. The problem was with the prop mounting. The direction of rotation was fine, but the prop edges were facing in the wrong direction. It works fine :)

Thankyou everyone for the replies and help :)

how did you fix it?

I have a 230si 7.4v 1200 lipo battery I have the same issue with my quad can anyone give me some ideas on how fix my problem

Willard2.03 years ago

I built a quad with very similar specs.I think your battery is too big and
too heavy. I am using a 2450mah 3s lipo. My AUW is 1100g and it has
plenty of power. Your quad should still fly, but it will be slow and heavy feeling.

Is your battery 2 or 3 cell? A 2s lipo won't spin the motors fast enough. You need a 3s lipo.

Can you confirm that all of your props are pushing air downward?

Bam Boy (author)  Willard2.03 years ago

Hi, yes I was using the 3S lipo battery. However, I found the problem with the prop mounting. The direction of air pushing was upward rather than downwards. It is fixed now :)

Wise Raven3 years ago

Did you check for correct voltage at each motor?

iceng3 years ago

Don't just mark the best answer but solve the question for us PLEASE ! ! ! !

iceng3 years ago

Are you spinning the propellers the correct direction to push air Down ?

+1. First thing I though of too.

Bam Boy (author)  steveastrouk3 years ago

The propellers are spinning in the right directions. Opposite propellers spin in the same directions. So I dont think that its the problem of the propeller's rotation.