loading

Rebuilt a Lenovo Thinkpad, now its not taking a charge ?

I've had to put a new power connector on a Thinkpad R51 laptop. The usual major job to remove all the bits to GET to the connector,(30 minutes) then  30 seconds of work to FIT the connector, and re-assemble....but it won't charge :-(

Ah, you say, he forgot to plug the new connector to the motherboard, but no, the PC sees the cable being plugged in (it beeps) and unplugged (it beeps again).....but it won't charge.

It won't work at all, if the battery is unplugged, so what ELSE should I look for ? Any ideas gratefully received !

THANKS TO EVERYONE WHO CONTRIBUTED TO THE ANSWERS. THERE WAS NO "RIGHT" ANSWER, BUT I APPRECIATE EVERYONE'S HELP


Thank guys.


Steve


sort by: active | newest | oldest
lemonie7 years ago
Having spent ~30 min trying to get my broadband-dongle to work, you are sure that all the connections are good? The beep-connected / unconnected is a data-line recognition rather than a power recognition, you mulitmetered the job?

L
steveastrouk (author)  lemonie7 years ago
Not yet....I can't face undoing all those damned screws again. It MUST be getting volts onto the board, else it wouldn't beep.


.... and the central heating packed up too, so I've had THAT in pieces as well....Success there though

Steve
Oh cack, I had a central heating system totally clogged with black-oxide, that's why you couldn't bleed it effectively... took a plumber to take it apart though. As I said, w/ref the USB, it beeps on data not power. My dongle was doing everything it should except being noticed by the PC (that's powered-up) turned out the connection was pulled a bit - no data (and no beeping)

L
steveastrouk (author)  lemonie7 years ago
BLOCKED with crap  ? How does it GET there in a closed system, you'd expect to reach some sort of equilibrium.
seandogue7 years ago
oh I hate ask but you didn't accidentally reverse the battery connection did you? (it shouldn't be possible, but shouldn't is a word I've often run into like a brick wall.)
steveastrouk (author)  seandogue7 years ago
Its a very polarised connector....and its beeping as it should...
yeah...I figured as much with the connector, but it had to be asked...

Ok..next...

What's the open circuit voltage on the battery? If it's at or above "charger-on" threshold, the charging circuit won't kick in. Have you tried depleting the battery pack?

And one more thing...does the system boot? "it won't boot, if the battery is unplugged" isn't coming thru clear to me...I read it one way and it won't boot, I read another and I don't know if it does boot, but I know it won't boot if there'e no battery installed...
steveastrouk (author)  seandogue7 years ago
No battery and PSU connected, it doesn't boot. Battry and no PSU and it boots fine. I have an hour's life left.

Steve
Of course you tested the power supply. I won't even ask. <coughs suspiciously>

I hate to say it, but I suspect you're gonna have to open the case up again...look at it as practice (lessens the pain) ;-)


steveastrouk (author)  seandogue7 years ago
Found it ! It IS the blasted laptop connector AND the cable. BOTH went faulty.

Thanks for the help guys.
grats. Glad you got it solved
steveastrouk (author)  seandogue7 years ago
Yes, of course I tested the PSU. Thank-you-very-much ;-)

You're right of course, I should be able to open it a lot faster "this time".

Steve
Lenovo usually has service and troubleshhooting guides as well as hardware maintenance manuals for pc and laptop.  They are free downloadable pdf files.
Might be something  there to help you solve the problem.