loading

Run Voyetra Sequencer Plus Gold (DOS MIDI sequencer) on Virtual PC 2007 or a modern PC with a USB MIDI interface?

Is it possible to run Sequencer Plus Gold on a modern PC, or under Virtual PC 2007 (and somehow "virtualize" the computer's USB MIDI interface to be an old Soundblaster AWE32 or some MIDI interface compatible with SPG) ?


sort by: active | newest | oldest

please see my page on voyetra on my site here: http://www.oldschooldaw.com/forums/index.php?topic=2368.0

seandogue6 years ago
I may be wrong, but if my understanding is correct, that would affect software only, not hardware...

Windows versions above 95 or ...ME/98...maybe... are to the best of my knowledge locked out of that deep a control route. Lower level OS security in more recent versions will not allow you to DIRECTLY access the hardware, which is required for use with the AWE's memory (and peripheral boards), although I do recall something still being able to access the standard sb16 stuff until ~ w2k.. That's the problem with alot of older tech. great stuff but obsoleted by the actions of the miscreant virus spewers due to its security threat at the hardware level (which is why alot of great  ISA and early PCI died with the switchover)

I probably ought to verify my installation disk is til  good and duplicate it before the aluminum rots. If you have one still, I might suggest that you consider installing it on another partition...can you even install an AWE-32 into your motherboard? I don't think my current system offers slots compatible with the cards...

I still have my Awe32 (and 16M of RAM!) along with an orignal EMU-Proteus -based Waveblaster-I installed into an older machine that still has 95, although I'll admit I haven't booted it in a god's age. I really need to, too, to capture a bunch of tailored midi output from the combo as audio tracks before the hardware finally giveout or reaches it's pre engineered death. Thanks for the reminder!.
apple-o (author)  seandogue6 years ago
Thanks for the info, I did not know that about the changes in the OS with respect to directly accessing hardware which made the old ISA/PCI cards obsolete. Interesting stuff...  And it tells me that Windows 98 would probably not work. Even in native DOS mode? (jog my memory - did Win 98 SE run DOS 7?)   How about Win 95, or Win 95 OSR2 or Rev C?  I think by OSR2 they had FAT32, which would give a little more HDD space than DOS 6.x.

I guess my line of inquiry would be redirected more along the lines of, would it be possible to install DOS on Microsoft Virtual PC 2007, and "install" a "virtual" AWE32 or old Soundblaster on the virtual PC, and through some trick of hardware virtualization, access my physical moderm PC's USB MIDI I/O from the virtual PC as though it were the game port MIDI I/O cable? I would guess that isn't something many people have wanted to do, so it wouldn't be built into Virtual PC, so someone would probably have to write some kind of driver or extension for it.

I'll probably just move onto my back up plan, which is to just dig out an old 486 or Pentium PC with ISA and install DOS 6.22 and a 16-bit Soundblaster on it.

95 is fine.. I still don't think the low level security will allow use of the Awe or related cards with the more modern OSes.

I gave up trying to get it working and purchase an X-Fi for my new system, so it's still in the old system. It's not a 486 class...just a dual 500 PIII...but it'll run w95 and has the constituent slots required, so that's that.
lemonie6 years ago
Probably, what OS are you running?

L
apple-o (author)  lemonie6 years ago
My main PCs all have XP pro or home. I have a Satellite laptop with Win 2k & 98 SE. I still have my DOS 6.22, Win 3.1, & Win 95 (all 3 revs) install disks (backed up in quadruplicate on various hard drives & CDs/DVDs) and a couple of spare old machines that I could install things on. But for convenience sake, being able to run it from one of my modern machines (via Virtual PC if necessary) would be nice. As Randy of the Redwoods used to say, "either way it's fine with me!"

lemonie apple-o6 years ago
Crikey, I thought I was the only guy to retain a copy of Win 3.1...
So it doesn't run under XP then?

L