loading

Sansa 2.0 gb. wont turn on?

When I try to turn it on it is saying, not enoughspace for Music DB please free 90mb. but the prob is I cant get it turned on not even hooked to the computer. I dont have a reset button on the outside of it anywhere...... If anyone can help it would be nice to know how to reset it even if I loose everything at this point I dont care. Thanks :)

sort by: active | newest | oldest
Burf6 years ago
Try this:
Make sure the player is turned off.
Press the ON button and hold for 10-15 seconds.
Turn it off again and then back on.
That will reset many Sansa mp3 players, hopefully it will work for you.
ARJOON Burf6 years ago
worked for me
Data6436 years ago
My uncle's Sansa, I fixed it by holding the power button and the home button for about 15 - 20 seconds (similar to iPod reset).
Vyger6 years ago
I have one of those. I have never run into that problem. It might be a firmware glitch. I just updated mine with a new utility that Sansa has on their web site. When you plug the player in it scans it and determines the firmware version and checks if there is a newer one. If you let it, it downloads the newest version and then updates the player. I would try doing that before anything else.

Another thought would be to put in a micro SD card so it has more space. It might not do anything but you never know until you try. Remember the limit of the SD on that model is 2 gig.
Danniell (author) 6 years ago
Oh it is an e-250 I forgot to add that