Simple Laser circuit problem?

I connected 6 fully built laser pointers (minus the battery compartment) in SERIES with alligator clips.
They each draw around 3v and 300mA (they are those cheap 5mw green pointers).
I connected the end leads to a 19.5vdc 4.5A laptop wall wart power supply.
I taped all of the laser buttons into the ON position.
Aannnd...   ...nothing happens.
The lasers are fully functional when using batteries, yet when wired up in this way there is no light.

What is wrong with this setup?
Thanks

EDIT: I can also garuntree that all connections are perfect, and there is pleanty of voltage and current coming from the wall wart.

iceng4 years ago
If  u made no mistake on polarity or good and proper wiring low ohmic connections.
And one is not burnt out !

I would assume the wall wart power supply is unregulated and lacks just a few milivolts
short of turning-ON one of the green LASERs.

Green Lasers are actually IR lasers with a frequency doubler stage
followed by a crystal that uses the high frequency to push an electrons to a higher energy
atomic shell and then they the electrons return back to the lower shell in steps.
One of these step down transitions releases energy as the green photon that you see.
madman11 (author)  iceng4 years ago
Yea I've triple checked and retried all my connections, and the power source is in fact slightly ABOVE the needed voltage, which I've found to work fine when batteries are 0.2v above necessary for the lasers.
iceng madman114 years ago
I Have IT !!!

There is too much ripple in the wall wart suppy

Try adding 100uF to 1000uF 35v or better safe 50VDC Capacitor across the
series lasers.

It should do the trick !
just not quite enough juice to get ignition. are you measuring current too?