Instructables

What could be wrong with my Kinroad Runmaster Sahara 250cc dune buggy?

I bought a Kinroad dunebuggy from a guy in Queen Creek, AZ for $1000. It is a yellow 2-seater with a 250cc engine and unifilter. It ran perfect when we tested it, but it has been downhill from there. I drove it around at home on the street for about ten minutes, then- uh oh. I was driving along, relatively slowly, when the gas pedal quit working. As in, it wouldn't make the cart move. When I pressed the gas pedal, it made the engine rev very loud, then stopped when I released. By now the cart was at a full halt. I pressed down on the brake pedal, then let go. That seemed to do it. It happened again in less than 30 seconds, but quickly subsided. I don't know if it was the braking that did it, or if that was just a coincidence. So that didn't happen again. I drove it around for a few more minutes, then shut it off. I came back to it less than an hour later. It started, I put in forward, and then when I pressed the gas- it died. No go. I tried again. No go. Finally, i started it, then revved it once for about 5 seconds in neutral. Then, when I put it in forward and gassed it, it went. It rode fine for a little while. I shut it off. When I came back and started it up- same as before. Whenever I gassed it, it quit. Finally, for whatever reason, it went. That lasted for about ten seconds. Then it quit. It hasn't started since, after maybe 20 more tries. So- any guesses as to the problem? Any help would be greatly appreciated.

manman694 years ago
Oh, and clean your carb, that will do it to.
manman694 years ago

Well ive had the same problem with mine and theres a few things it could be. One beeing the automatic choke is known to stick which will cause it to bog, another is the shifter cable, will move and jump out of gear, my bolts sheared out where the bracket atatches to the tranny, gotta be super tight, and the last beeing clutch, upgrade it because sooner or later it will burn out anyways. Go with the MRP Dr.Pulley hit clutch, works exellent. But check all your wires to be sure, in those even the ignitions will cause the machine to die if they go, dont know why. Hope something in here helps. Good luck.

kathyzjim5 years ago
Two possibilities.  Most likely is the fuel filter is clogged.  Plenty of fuel at idle or throttling without load, but with a load more fuel is required.  How to test?  Remove the fuel hose from the Carburetor, and place it into a cup.  Allow fuel to flow into the cup.  After a few seconds, the fuel flow will become a trickle.

Second possibility is improper MainJet Needle adjustment.  Pull throttle cable from top of Carburetor (large ring-nut).  Pull spring back and disengage cable from piston.  Push Needle from piston.  There is a E-Clip on needle, move it one notch toward the pointed end of needle.  Reassemble.  Why?  If fuel is too lean (clip at end of needle) engine will stumble upon throttling.
iPengu5 years ago
Go to http://www.buggynews.com/ site dedicated to buggies. Positive the community and several dealers on there can help you out. You can also find out about performance parts there also.
snowpenguin (author)  iPengu5 years ago
Yeah I've seen that before. Thanks anyway, it's fixed.
Nice to hear, have fun with it.
lemonie5 years ago
Might be a dodgy-clutch / transmission. It would mean taking the thing apart, or seeking professional help.
http://www.reliableatvs.com/pdfs/parts/cvt-transmission-basics-guide.pdf

L
snowpenguin (author)  lemonie5 years ago
Hmmm... That link seemed to be for adjusting RPMs on a scooter for maximum HP. BTW, I believe the buy said it ad a centrifugal clutch or some whoziwhatzit. You have to rev it for a second before it will move once you put in forward. He said 'it basically has two transmissions.'
Yeah it'll have a centrifugal clutch. If the clutch doesn't engage the thing won't move. If it engages too early it'll stall. I've known cheap clutches of this type break. L
snowpenguin (author)  lemonie5 years ago
We brought it out today and low and behold, it ran. We started it up, and it soon died. Each time thereafter it lasted a little longer, until it stayed on. I drove it around for about 45 minutes then it died. I started it again, and it was loud. It would go in reverse, but not forward, and then nothing. My dad thinks now that it is a choke problem, since giving it a long rest cooled it down, then driving it again heated it up. Thanks anyway :)
Well, with 2-strokes there is also the option of taking the carb' off and giving it a good clean - consider that as an option if it does this again. L
snowpenguin (author)  lemonie5 years ago
Nope, it's a 4-stroke. Oh well... We'll have to take it in if we can't figure out how to fix it ourselves. The manufacturer owner's manual and repair manual will be on the website this week. Maybe that will tell us what to do.
4-stroke with CVT? Ah well, unless it's fuel-injection there's still the carb' to play with - best wishes for it. L