Why I can not complete lesson 1? I finished all other lessons. ?

Why I can not complete lesson 1? I finished all other lessons.

sort by: active | newest | oldest
bekathwia6 months ago

Thanks for letting us know! I'll report the matter to our dev team.

The bug is related to a quiz question not showing. I was able to answer it using jQuery, but it requires jQuery/HTML/Chrome knowledge. Although, I probably could have just followed the DOM tree up to the hidden element first. Oh well, the hard way sounds more impressive I suppose.

After looking into it a little more, it looks like the problem is the question (unintentionally) appearing in a hidden `pre` element with a class of `quiz-json` (these elements appear to show the JSON format for the question and are all hidden). I'm not sure how Instructables handles these questions, but moving the question outside of that element should fix the problem.

Any progress on this issue? As of 10/26/17 I cannot get Lesson 1 to complete either. Yes, I have correctly answered the question.

Great course! Thanks.

2017-10-26 Internet of Things Class.png
mjrovai (author) 4 months ago
Hi Beka,
Yes, I did. I returned several times to lesson one. The corrected answer included was kept there ("the automatic chicken door") and a message that "That's correct". But lesson 1 stays with 83% complete, independent of quiz result. I tried 2 different browsers, with same result. I understood that others had same problem at lesson 1.
Thanks
Marcelo
PaulK230 mjrovai4 months ago

The problem seems to be that there is a second quiz question that nobody can answer.

ljohann6 months ago

same here.

bekathwia ljohann4 months ago

Did you correctly complete the quiz?

ljohann bekathwia4 months ago

yes

mjrovai (author)  bekathwia4 months ago
Hi Beka,
Yes, I did. I returned several times to lesson one. The corrected answer included was kept there ("the automatic chicken door") and a message that "That's correct". But lesson 1 stays with 83% complete, independent of quiz result. I tried 2 different browsers, with same result. I understood that others had same problem at lesson 1.
Thanks
Marcelo