loading

Why can't I right click?

Well, I don't know if it has to do with recently getting a new mouse, or what, but I can't right click. I even tried my old mouse again, and it doesn't work on that either! What should I do?

EDIT: Nevermind, I restarted my computer and it works now. Odd.


sort by: active | newest | oldest
Try reinstalling the mouse driver.
DJ Radio7 years ago
Because you fail that hard. 

(JK =P)
chopstx7 years ago
Why is this in K'nex?
travw (author)  chopstx7 years ago
What?
chopstx travw7 years ago
Oh. Whoops.
Reinstall the mouse driver. If that doesn't work check the companies site that makes your mouse.
I have that problem, except the mouse (I have two) doesn't move. I can use all the buttons and stuff, but it won't move. I think my problem is hardware failure not software because my other mouse works. If neither work for you it is probably software failure.
assuming you are using windows...
go into control panel
go to printers and other hardware
go to mouse
make sure it is set up properly.
If you are using a PS2 mouse, try using a USB mouse instead.