loading

Why is my IBM thinkpad T42 so slow?


I just got a new hard drive for my t42 and reinstalled ubuntu but it is just extremely slow. I am using it in wireless mode, and I have multiple computers connected to my modem in my house. It takes about 10 minutes just for me to get to my IGOOGLE page. My laptop also keeps cutting in and out of connectivity. Thanks

sort by: active | newest | oldest
orksecurity5 years ago
Is the problem the Thinkpad or the network connectivity? It sounds like you're out of range and only getting occasional packets transmitted through. If you're on wireless: What happens when you move close to the router? What happens when you plug into wired Ethernet?
acidbass (author)  orksecurity5 years ago
I have not tried ethernet yet but I use my laptop right next to the router and it cuts in and out
Radio noise -- a wireless phone in the same frequency range, for example -- can do that. So can hardware or software problems, but the right way to test that is to connect to another router somewhere and see if the problem is associated with that particular router and location or with the PC.

If you're right next to the router, a short cable is the cheapest and most reliable fix.
acidbass (author)  orksecurity5 years ago
well at my business i have wifi and at starbucks and at home and it does fairly well now in all three after getting a usb card thanks for the advice
Vyger5 years ago
You have a choice of the router or the wireless NIC . If other stuff is working on the router then your down to the NIC in the laptop.
I just replaced a wireless router for a library were the wired part worked perfectly but the wireless didn't work at all.
Get, borrow, whatever another notebook to check the wireless function. If it works then get a replacement card for the laptop. Hopefully that will fix the problem.
acidbass (author)  Vyger5 years ago
yeah i know the router works (my parents have 3 laptops running off of it wireless-ly)
Vyger acidbass5 years ago
Great, then you know its the notebook you have.
You can try uninstalling and reinstalling the onboard card but chances are that will not fix it. You need to get a USB wireless card.
acidbass (author)  Vyger5 years ago
did so and thanks