loading

Why this simple LED circuit using IRF540 not working ?

This IRF 540 works well alone, and the it is very sensitive.
But to add an LDR, i tried it with a BC548 transistor, but it dint work, why ?
I am new to electronics, some one please help.
Instead of the 2.2k resistor, I am giving +ve output from an IR motion sensor.
If I connect a  small LED to the motion sensor, that LED alone lights up, but the IRF 540 is not working based on the input from the motion sensor through BC 548 (also tried BC 547, 8050).
Connecting the motion sensor's +ve out put directly to the IRF 548 works, but the LED is not bright, voltage is too low.
Update: I solved it just by using few resistors.
Instead of using the 548 transistor, I used resistors.
The Motion sensor output's -ve all time, then the IRD540 turns off.
When there is motion detected , it outputs +ve and it just works!

Picture of Why this simple LED circuit using IRF540 not working ?
sort by: active | newest | oldest
-max-3 months ago

Up the voltage to about 10V or more, and it should work.

.

MOSFETs like that need at least 6V on the gate to conduct a good bit of current. Anything less than about 4V and the MOSFET will be off, and higher voltages than 10V will ensure a nice strong gate drive.

That depends entirely on the Mosfet, and its topology. You can get Mosfets that switch to modern logic levels.

Downunder35m3 months ago

I just say:
That happens if you don't read datasheets or fail to understand them.
;)

steveastrouk3 months ago

You need to use a LOGIC LEVEL mosfet, not a 540, even then, at 3.7V the thing might struggle.

If you look at this link

http://www.digikey.com/products/en/discrete-semico...

You'll see close to 40,000 possibilities !

Here's more

http://uk.farnell.com/webapp/wcs/stores/servlet/Se...

+1

You only showed up 24 min after I posted....

Storms must be real bad where you are.

iceng3 months ago

+1 To Jack.

This 100V 20A transistor calls for a 10 volt gate source to fully turn ON...

But would work down to a Vgs = 4.5v to pass LED Current.... Unfortunately your battery is a 3.6v which is o.9v less then needed not counting the NPN forward drop.

------------ I would recomend ------------------

I assume a white LED 3.4v ..... Then 1W / 3.4V => 294 ma LED

Series Resistor = [2 batteries 7.4v] - [1.5v 2N2222 drop] - [3.4v led] = 2.5v

Series Ohms = V / A = 2.5v / o.294A = 8.5 ohms

Series R power = VxA = 2.5v x o.294a = o.732w Use 1 Watt 9 ohm

yy.jpg
Jack A Lopez3 months ago

My guess is that voltage on the gate of your IRF540 is too small to turn it on.

I mean, you should check the data sheet to know for sure. It's just that I seem to remember thinking most of these MOSFETs wanted kind of substantial voltage, like 5 volts, or sometimes 10 or 15 volts, to get fully turned on.

By the way, LEDs usually require some kind of current limiting, like a resistor in series if its a low powered LED (like <30 mA) , and something more complicated, like a constant current regulator, for high powered LEDs. Just connecting a voltage source across a LED is usually a bad idea.