Working, but not quite as expected ?

Hi Becky, here is some feedback on my experiences in this module. In my enthusiasm to get this going, I plugged my new Feather Huzzah straight in to my PC without reading all the way thru the instructions first. I was so impressed by the pretty lights, I forgot to unplug it again. However, Windows 7 recognized something was there and found a driver that looks like the right one ( Silicon Labs CP210x ). So I skipped that part to see what happened. Later steps of the tutorial have worked too well for it to be entirely wrong, so should I leave well alone ?

Also, in the WiFiClientBasic example, after changing the code from 192.168.1.1 to a known site, I was still not getting much of a response. I would just see 'connecting to google.co.uk' and on the next line 'closing connection'. Initially I noticed that the line 'client.print("Send this data to server");' used .print and not .println and hence was not sending a 'return', so I changed this, but to no avail. So I switched to an SMTP server because I knew what the response should be, using 'smtp.mistral.net' and of course, port 25. Still no response coming back from the server. Then I noticed the following in the code :-

//read back one line from server
String line = client.readStringUntil('\r');
client.println(line);

Surely, the last line should be :-

Serial.println(line);

After changing this I now get the correct response :-

220 Mistral Internet lon-gs3mx-out.mail.mistral.net ESMTP

Otherwise instead of printing to the USB Serial Monitor, is it not just being sent back to the host it came from ? I am using Arduino Software 1.8.1 as per the tutorial, but I understand from reading others' posts, that there may be a 1.8.2, so i don't know if upgrading would help...


bekathwia2 months ago

I'm not a Windows user, but if you can successfully program the board with Arduino then I'd say you have the driver installed properly. =]

About the example, it's a good question-- one I would bring up with the authors of the library: https://github.com/esp8266/Arduino/issues

However I doubt that line of code has any effect on your ability to connect to the net, but rather something else is wrong, like a typo in the network name or password, being on a network that requires captive portal login or device whitelisting, trying to connect to a 5Ghz network (not supported by the ESP8266), etc.