loading

how can I embed images in an instructable ?

I have read a thread detailing image embedding using <img src=...
https://www.instructables.com/id/How-to-Embed-Photos-in-an-Instructable/

However, I can't make this work :
I upload the images.
I embed them using the img html tag.
The image is correctly shown in the edition window.
When I press "preview", the images are no longer shown.
I have tried different sizes and formats, some have briefly worked (= were shown in the preview window), but all ended up disappearing at one point or another.

sort by: active | newest | oldest
fgorenc1 year ago

why is dropbox (public folder) not supported?

bwrussell2 years ago

I just posted an Instructable with an embedded image using <img src="URL"> in the HTML editor pane and it's working fine. I uploaded the image to my picture library here and linked to the full size copy of it here.

It sounds like you're not using the source/HTML view. The button has moved to the other side of the editor pane and appears as "</>".

image embbed.png
IverB (author)  bwrussell2 years ago
Hi bwrussell. Are You using the pro version of the editor ?
I do not have the button you highlighted on my editor...
bwrussell IverB2 years ago
Yes. I thought I remembered hearing that was part of the PRO feature set.

The editor simply sucks at all ends ;)

I tried all sorts of ways and both the normal HTML tag as well as the extended that defines the preview size work just fine - even embedding a direct link to a picture.

Thing is that it is does no work in any way someone expects it (from using forums and other online editors).

In 99.9% of cases the culprits are called "space" and "Enter" key.

When adding a link make sure (for embedding in text) there is a space between the last text and the beginning of the link.

At the end of the link ALWAYS press "Enter", just moving or typing on will embed the link as text or make it disappear.

I usually prepare the Instructable in a normal text editor with the plain links in it.
Convert the links to HTML tags and them paste the lot into the editor here.

Press "Enter" somewhere in the text and all links show up and work.
Downside is that the editor here has a mental problem that kills all formatting, so you have to do this all over again.

For smeller things just paste the link with a space in front and press "Enter", it should show up with no problem.

+1