loading

how to solve soldering problem?

I soldered a lot but from some time,my problem is that after tinning the tip and putting in soldering paste(when needed), I get a layer of a sort of oxide or something,but that is not what bothers me. The big problem is that the solder is not tinning on surfaces (wires and component leads). what can be the cause?(i'm guessing the solder since the problems started after buying new solder)

framistan4 years ago
Hopefully, you purchased ROSIN core solder. Not ACID core, which is for plumbing not electronics. Also your iron's tip must have a sillvery melted-solder area, not completely black. Some cheaper irons just have a copper tip. Those tips quickly become blackened and you must use a metal file or grinder to get back down to the copper and immediately TIN the tip with more solder. Also, when choosing solder, it is best to choose a thin-guage solder for most electronics. They sell solder in all thicknesses. The thick stuff is good for soldering large wires with a propane torch ... or copper pipes (acid core solder). But the thin solder about the thickness of a 7 or 9 millimeter pencil lead is best. If you are soldering VERY tiny parts such as surfacemount electronics, then you want the thinnest solder you can find, and an iron with a very low wattage and small tip. Also, as you solder it is a good idea to every once in a while wipe the tip on a WET sponge. This helps keep the tip from oxidizing and wipes away the melted crusty solder from the tip so you can get a better joint. Most people NEGLECT wiping the iron on the sponge because they dont even have one nearby. Keep an old soda-bottle full of water nearby your solder station. Drill a small hole in the top of the bottlecap. Squirt water onto the sponge to keep it moist but not soaked. The water bottle nearby will help a lot.
rickharris4 years ago
IF your solder is lead free then it will need a higher temperature to make the joint - Either a new soldering iron or take a little longer to allow the heat to penetrate the wires.
Re-design4 years ago
Not enough heat?
Flux wrong type?
Solder wrong type?

What does the label on the solder say?